Unable to create/choose/alter loot filters

SOLUTION FOUND - Leaving topic up for others with the same problem.

I did a back up of all my filters, and then deleted all the filters in the folder. That resolved the issue. Then i started copying the backed up filters over to the empty folder until it broke again. One of the filters got corrupted after the update, and that affected the whole loot filter window. Deleting that specific filter fixed the issue.

Opening the filter in notepad++ it didn’t have a standard xml format, and was just a string of hundreds different characters.
The file size was also 2-3x higher than all other filters in the folder

I created a new character after the 0.9.1 update, when i tried to apply a lootfilter to the character, the dropdown menu doesn’t work, It’s not showing any of my previous filters in the list (they are still in the appdata folder).
After that I tried importing a new filter. But that is also bugged. The Paste Clipboard Contents keeps showing “the clipboard does not have a valid loot filter to import” message even though I have copied a valid lootfilter.
After that I gave up, but i was unable to exit the loot filter window, and i couldn’t open any other window (Main menu, Settings, Forge etc…) So i had to Alt-F4 and log back in.

I tested it on one of my other characters. They still had the most recent lootfilter enabled, but I am not able to alter any rules, and the dropdown menu is also still bugged on that charater.

I’ve uploaded a screenshot from one of my high level characters with an active lootfilter. The screenshot shows me trying to open the dropdown menu, and you can see it shows a sliver of the dropdown menu (marked with red)
Also it shows 0/50 rules even though rules can be seen in the filter.

  • I’ve tried verifying the game files on steam
  • I’ve tried reinstalling the game