Timeline Quest Echos not loading objectives randomly

Hey there,

Online Forge Guard char, level 63 am experiencing a regular issue with non-empowered Monolith Quest Echos. Been doing Fall of Outcasts, I am loading into the quest echo and there are no quest objectives in the Quest list on the right.

I can run around clearing the map, but no quest triggers occur and there is no way to “end the map”.

I have had to reload echos many times and there doesnt seem to be any reproduceable way to “make it happen” on every load.

Side notes that may be related:

Loading into maps usually requires that I do nothing for a few seconds though to let it fully load properly. If I immediately move after loading into a map, enemies may not be visible or load in after I have run past them. If I dont wait, minions also dont spawn for a noticeable period of time. Perhaps the same is happening with quest objectives and sometimes its timing out.

Note, I am playing EU West, from South Africa so ping times are 160ms+ at absolute BEST.

Player.log (202.3 KB)

Further to this problem. Loaded into the The Altar of Flesh and no quest objective loads and none of the usual triggers work and you cannot progress to Abomonation stage.

Have also noticed getting connection to server problems happen if I wander around in these borked maps. So it could very well be timing out problems.q

Additional info - this issue with no quest objectives doesnt seem to happen on normal Echos… Only Quest Echos. At least as far as I can see.

This is happening to me right now with “The Dark Ascent” quest echo #2 in The Black Sun monolith. Haven’t seen it happen until now and I have 2 other characters above 65.

I have tried 3 times and have no been able to complete it yet.

Non-empowered, Forge Guard (not sure if coincidence), i’m in CA but I don’t know how to check what server im connected to. 1-2AM PST. I left the campaign to do monos right when I finished getting all skill points and idol slots (in lagon’s chapter).

Bumping this thread as it is making the game unplayable for me since I can’t reliably progress.


I would say a majority of the time the quest echo objectives do not load at all (see quest log in screenshot). If you attempt them many times it may work, however the only way I got past the second quest echo was quitting and returning to the game a week later, so who knows.

Player.log (1.5 MB)

I really want to grind but this keeps me from playing.

Just found a way to possibly recreate this.

I do not think the “instance” is resetting. Originally I died to the boss and the quest echo started not working on next attempts.

I zoned in, saw that the quest wasnt working, teleported out.

I zoned in again and it still wasnt working, however my old portal was still there.

Switching characters did not fix it, im hard-stuck in monoliths, can’t do anything about it unless there is a way to reset instances.

Edit: Still broken in 0.9G, literally cannot progress.

I am having this same problem, also playing Forge Guard.

I am on the ‘Fall of Outcasts’ timeline. Had to load the first quest echo ‘The Ransacked Camp’ three times to get the quest to populate and have tried the second quest echo 5 times with no luck so far.

I haven’t had this issue on any other characters so far. Hope this gets fixed soon.

Any ETA to fix ? I have 2 Forge Guard that can’t finish Mono and go to the next higher Monolyth.
I have no problem to create a new FG if that solves the bug, but when I get stuck in mono again I get very frustrated.

Sorry for the wrong reply.

Same thing is still happening.

The only way I have found to get around the problem is to reload the quests over and over holding my thumbs. :wink:

A critical thing for me - at least from my observations - is to not move the char or use any skill when loading into a new map. If I wait for 30 seconds, and if I am lucky, the quest objectives appear. If I immediately move my char, then there is zero chance of the quests appearing.

Gut feeling for me is that there is a problem on the loading of the special Echo quest objectives.

Cannot recall the same happening in normal non quest echo nodes ever… Only on quest echos.

So you “can” progress… its just soul destroying to do so

For those experiencing this: are you using Smelter’s Wrath, at least once during the play session?
Thanks for mentioning this thread elsewhere Vapourfire, I hadn’t seen this thread. So far Eagle’s tests have demonstrated that the issue appears to be specific to Smelter’s Wrath, but some additional confirmation would be good, since it’s a strange connection.

Nope. Unfortunately not using Smelters at all so dont think thats the link unless its more general to Forge Guards.

Not sure how easy it is for you to check my online char “Pantagruel” but its a 2h Rive, Lunge, RoS, Manifest & Forge Strike build. Was using the numlock trick to recast RoS but when I disabled it I found that objectives would load more often than not - hence my comments above about not using skills/moving seeming to make a difference.

Unfortunately I dont have any other builds (i.e. non Forge Guard) to test alternatives at the MoF levels but none of my offline Forge Guards suffer the same issue. Only seems to be online.

I will reiterate that you can get by by retrying - i.e. it doesnt seem to be as I originally thought as only restricted to certain Timelines or Quests… it seems to happen everywhere in MoF and entirely randomly as far as I can tell.

Interesting, in which case Ring of Shields is my new top suspect. The inconsistency makes this difficult to nail down, so any additional details about what might seem to cause the problem is appreciated.

If I immediately move my char, then there is zero chance of the quests appearing.

Do you mean moving your character right before selecting the echo, or immediately after it finishes loading? Or are you somehow able to move while it’s loading?

You may be right about RoS.

Moving immediately as the map is loaded is what I meant but see below.

I have been messing around a little more and have found some more things:

  • I am doing Black Sun, Dark Ascent.

  • Offline Char, no problems at all with RoS or any FG - map runs fine every time.

  • Online char, FG:

  • Immediately obvious as when the screen is greyed out with the Loading, you can see the quest list on the right doesnt update with a quest objective. Normal Echos update this immediately, quest echos dont seem to so you can see almost the moment you start the map if the quest objective is “stuck” or not.

  • I have tried with and without RoS on my toolbar

    • without it, it seems like the map objectives load.
    • with it BUT not active at all, it seems like the map objectives load
    • with it BUT ACTIVE, it seems like the map objectives randomnly dont load. This includes having the numlock trick active to recast it while loading the new map

Big Caveat here, I have only testing this in a very limited way a very limited number of times so I cannot say for sure if RoS is actually the problem or some other combination of factors.

but it does seem like a place to start

Can you share your skill tree for RoS?

Thanks! I’ve found the issue. While waiting for a fix, you can avoid the problem by ensuring Ring of Shields is not active while loading into the echo.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.