The Ruined World - can't dispel barrier to leave town

I logged out after getting the quest and today when I logged back in the first thing I did (on this char) was run to the door and click the barrier. The dialog pops up to “? Dispel the Barrier” but clicking it just closes the dialog without removing the barrier

Is there supposed to be some sort of Item I need to use to do this?

Side note: I didn’t bother screenshotting since its just me with a dialog and then it disappears. can add if you need.

Player.log (33.2 KB)

1 Like

Are you talking about after you get the quest “The Ruined World”? I’m also stuck in The Council Chambers. The barrier just will not dispel!

1 Like

I have the same issue with dispelling the barrier and I’m not able to continue further.

1 Like

Same problem here. Also Elder Gaspar appears as a white square on the map/map overlay.

Worked after second mastery quest . I guess it is by design but it is confusing.

Hey guys so a quick update. I fixed the issue go back to the lower district and fight the boss there again. That will open a portal allowing you to take your class mastery. After returning you will be able to get past the barrier now!

This indeed fixed it for me, thanks!

I had logged out in the Council Chamber (hadn’t unlocked the barrier yet) before the 0.9.1 patch, but when I logged in today I seemed stuck (barrier was up but no quest to go get the key (again?)) and all my quests (all in Ruined Era: The Ruined World, The Lesser Refuge, and An Ancient Hunt) pointed past the barrier.

After getting The Thing after going through That Portal, I’m able to dispel the barrier.

Thanks, Not sure if this is a continuation of the issue, but I’ll explain it here just in case:

  1. Went back and fought the boss
  2. Got the teleport to End of Time
  3. talked with Gaspar and got my mastery, teleported back to ruined era

Now I have the Quest Immortal Empire
'Speak with Gaspar in the End of Time."

I cannot progress this, similar to the dispel barrier issue I speak with him, click the ‘?’ option and the quest is not marked as completed