Temporal Sanctum Bug

So when i try to do the dungeon… Every time at the start when i press d to shift into another timeline i cant enter the dungeon further because there is no door… I seem to be the only one having this problem…

Its the first Dungeon Tier


1 Like

Can confirm this has just happened to me too. Level 80 version, no doors are activated to be able to descened from the starting area of the Sanctum.


Okay the way i unbricked it… I called a friend to enter his realm and do the dungeon with him… it works now for me

But if you’ve had to go to his realm, then he had to use a Temporal Sanctum Key as well, so 2 keys were used. I just had to use another key and it worked the 2nd time round. Could do with being fixed so keys aren’t just wasted

Can confirm. Rip keys.

Had the same problem in T2 Sanctum today, RIP key. Maybe it is not related, but when it worked yesterday, I also had another bug : I was able to go through bars using Shift ability in the Sanctum.

Same issue here, 4/7 keys failed so far

@OfficerPenus This sounds like the same problem you’ve were having.

Curious for anyone experiencing this bug: Are you spamming D (time shift) before the voiceline triggers? Wondering if the voiceline vs timeshift has to happen in a certain order or something…

Note: I haven’t experienced this bug yet myself.

Lost 3 keys in row…


In case the devs look at this i wanted to add something as I too have seen this bug multiple times, I have been unable to entire the dungeon entirely, as well getting into the dungeon, but then in the room just before the boss i get trapped, and cannot enter the boss arena, or do anything.

First and only time I’ve ever tried Temporal Sanctum and I experience this bug. Used a key and loaded in fine. Able to use ‘D’ to shift between the phases. However, there is no ability to actually go down the path; there is an invisible barrier in the uncorrupted zone that prevents going anywhere, hence not able to actually leave the first room.

Can confirm still bugged. Not able to enter either side.

Same problem can’t leave first room of the dungeon :frowning:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.