Stuck on loading screen when loading into The Darkling Pier

Whenever I try to load into The Darkling Pier, I just get stuck in the loading screen for the location. I can hear my character moving and hear menus open & close, but the loading screen persist forever. Loading in from the previous area and trying to teleport to a friend both cause this forever loading screen.

Have tried relaunching and the problem continues. I am unable to progress through the game solo or in a party. Any potential fixes?

2 Likes

Similar glitch here, but in the Drowned Thetima quest in the Ending the Storm timeline. Able to open the menu and can hear things like character screen and inventory opening, but the loading screen persists until I leave the game. I was able to complete this timeline before the 0.90 Patch on this character.

2 Likes

Got the same problem as OP, stuck on the Darkling pier (impertial era) loading screen. I leveled other two characters (all of them in online mode), and this wasn’t a problem. Now my pally can’t progress in the main quest because i can’t get past the pier.

The only diference to OP is that i can’t hear the character there.

Tried with my other chars (one at monos, the other halfway 50) and the loading screen never ends.

I created a bug report about this area as well. Had to park that character since I couldn’t progress.

Now I’m on another character and he won’t load into Champion’s Gate. This will be the 3rd character I’ve had to park because progression is being halted. Sure I don’t have to do Arena but yeah I’d really like to.

edit: And now the only character I had left also can’t get to Champion’s Gate. Guess it’s time to finally step away. I tried! :frowning:

Same problem here. Leveled 2 characters and both got stuck on the loading screen (leveled the other to test if it always was tlike this). And same happens when I try to load Temporal Sanctum too on my starter.

I have this issue also, cant run endgame without finishing this mission. Not yet at empowered monolith.

Edit Update: After playing a different area like the black sun and then going back to Ending the Storm. It work, it finished loading

I have the same problem… I cant progress the main story. I relogged, restarted the game. Nothing helped… :frowning:
Sadly, this is my first character ever in LE…

EDIT:
Please repair the game files in your stream library, Properties, Local Files, Verify integrity of game files.
It worked!

I mentioned this in another thread about this bug but I’ve noticed that at least for me this only seems to happen if I attempt a quest echo as my first echo after entering the game. Doing a normal echo first then the quest seems to always works without issue, and quest first always results in a stuck loading screen.

2 Likes

This worked for me as well - thanks for that!

Reparing gamefiles didn’t help, this did, thanks.

Had the same problem, game got sruck on loading screen if I tried to do a quest echo just after the game launched.

As mentioned above, completing a regular echo first after game launch worked for me too

2nd time in two days. This time in the wengari battleground.

3rd time 2nd attempt…same problem.

4th time…3rd attempt . I’m going to try above mentioned fix (doing a non quest echo). I’ll report if it works.

edit: It does indeed appear that attempting a quest echo upon log in is the culprit. Re-logging and doing a regular echo first solved the problem.