Steam is now required!

I bought the game on Steam. I’ve been playing it for the last year and a half on Steam, I literally played it earlier today and never had any problems. Now all of a sudden I get this message and I can’t get in the game. I tried restarting the game/Steam/the PC. Nothing helps?!

Same here. Sounds like its not an isolated incident.

Yes, same here. Could play earlier today, but now Login is not working. Already tried closing Steam and re-opening Steam, but problem persists.

To add: I also just rebooted my computer, but that didn’t help either.

Same here :frowning:

Same issue - Steam is dumb - let people play games without the intrusion. sigh - miss the good ole days

Getting the same error, kind of surprising since I was on earlier today.

Same problem here. Was super excited to play today. Guess the universe is telling me to get up and clean instead

The same thing is happening to me. Where can we go for help?

Seems like a global issue, both here and on Steam people are posting every minute about it. So I believe EHG knows about it. When they’ll fix it, that’s a different topic.

Same here. Played couple hours ago just fine.

same here… any fix for this ?

Me, too.

I haven’t played in many months, but I got this message today and was prompted to “Update Account”. So I clicked the button, signed into Steam, and migrated my LE account to Steam. The page said it would take 10-30 minutes for the game to appear in my library, unless I purchased the game from Steam, in which case I was assured the game is ready to play. So I launched the game again, and still getting the message.

It has to be some service issue with either Steam or EHG, since it’s happening to everyone. I’m sure the team is already aware of this and working on it. I’m also pretty sure that we can expect some announcement and/or fix soon.

I doubt any player will have any other info, considering everyone is basically echoing “Me too”

I bought the game on Steam too. - Same problem.

“Last Epoch is currently down due to a Steam service outage. Services should resume as soon as Steam is back up and running. Apologies for the inconvenience.”

Statement from Kain on the Forum.



Hi, I still experience this (Steam running under Arch Linux). The curious thing is, under Windows it is working fine again. I already tried clearing the steam cache and I also completely reinstalled - didn´t help.
What can I do to get it running again?


Hi, I found a workaround for all the people still experiencing this. Have Steam running and then start the game directly via proton in the console… That works. :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.