"Spellblade's" Affix doesn't exist

I have leveled a Sentinel to lv 42 with a filter on from level 1 that searches for Swords with the “Spellblade’s” affix. After not seeing one till level 20, despite having seen multiple on my 8.5 Paladin with the same exact loot filter, I got suspicious. I started doing some searching and I believe the issue lies with the change noted in the patch notes changing “Spellblade’s” affix from “Adaptive Spell Damage” to “+Spell Damage”. The Loot Filter reads “Spellblade’s” affix as “Spell Damage” the same as “Imbued”, so I believe that that filter is checking for the “Imbued” affix twice, rather than correctly checking for the “+Spell Damage” affix. It’s also possible that swords aren’t rolling with the “Spellblade’s” affix at all due to the “+Spell Blade” affix not existing and swords being unable to roll with the “Imbued” affix’s “Spell Damage” prefix.

To test this conjecture further, I have tested multiple swords and tried to add spell damage through the Forge mechanic and every single one tells me that Spell Damage is not available for that weapon, despite being available for Scepters and Wands.

Can anyone confirm my findings that the “Spellblade’s” affix is not present in the game? I could chalk this up to completely rotten luck, but given that forge does not differentiate between “Imbued” and “Spellblade’s” in the “Spell Damage” shards, I’m banking on “Adaptive Spell Damage” wasn’t correctly transitioned into “+Spell Damage” during the patch.

I have taken some screenshots of my 8.5 Paladin that definitely had “Adaptive Spell Damage” on his sword. Here are his Shards filtered by “Spell” to show he has “spell damage” shards, and Here is the sword showing the “Spell Damage” on it, but unable to increase spell damage despite having the shards in the previous image.

I came across this thread for the same reason; I’m level 96 and have yet to find spellblade affix shards or items.

Just found my first one, in a dungeon. So the affix shard either is a dungeon only drop, or is giga-rare.

I ended up finding a single sword across two characters (second was Spellblade) that had spell damage on it and I couldn’t upgrade the affix, I tried to shatter it to see what shard it gave but I didn’t get that specific shard. It could just be a 0.00001% drop rate or something, but even that seems like it could be a bug.

Bumping for visibility.

I have three separate loot filters across three characters and each has the first filter in the list searching for and emphasizing “one handed sword with spell damage” and I still haven’t seen any drop over a combined 95 levels, 191 combined levels if you include PandaPoacher’s 96 levels.

For a “common” drop, this is pretty rare.