My Account
× My Account Forum Buy Now

Last Epoch Forums

Sound Stutter

Hi!

I’m having an issue with the audio of the game, its start to stutter when another audio source takes place. For exemple, when I start to cast a spell the music starts to stutter, or when sound of footsteps take place.
I uploaded a video on youtube to demonstrate: Last Epoch Audio Stutter - YouTube
When the character don’t move the stutter stops, or when you disable some of the other sounds its stutter less.

Hey there… Welcome to the forums…

There have been reports of sound stuttering before but not recently… Issues like this have been related to a few different things in the past - including bugs, general system performance/resources, slow harddrive, audio drivers/audio apps, faulty or conflicting audio hardware, audio routed via virtual audio devices or even issues via HDMI audio, corrupted game files, stuttering based on OS version and one issue where someones wireless headphones were faulty…

Unfortunately, other than some actual bugs that the devs fixed in previous game versions, its generally hard to debug this kind of thing as there is usually nothing obvious as a starting point for troubleshooting and there isnt usually an error that is logged or something to work from.

A few things:

  1. Please post your player.log (game debug file), le_graphicsmanager.ini (game settings file) and the output from a dxdiag report (summary of your system, hardware, drivers etc).

  2. Please can you do this testing without ANY other applications running - doesnt matter how irrelevant they are - there are known instances where apps can conflict with the Unity game engine or the FMOD components handling sound. This even applies to unneccessary services that may be running/apps installed as services. This is doubly important for anything that hijackes audio for streaming or post-processing.

  3. Make 100% sure that ALL drivers on your system are up to date and appropriate for your hardware (i.e. sometimes people upgrade hardware but leave older drivers from other vendors installed). This obviously includes audio related drivers BUT you should also double check any other device drivers like GPUs, BIOS updates etc… especially if you are using integrated audio etc.

  4. Make sure that your game installation is ok… If you are using Steam, then run the Game File Verification option to ensure that all game files are ok.

  5. Monitor your system when testing this… I.e. what is your CPU/GPU doing when this happens? Are any processes spiking - is anything accessing your harddrive at the same time… Is anything happening in background that could be “stealing” resources from the game? Obviously this also depends heavily on your system hardware capabilities AND what settings you are trying to run the game at.

  6. Have you attempted to use other sound outputs to see if the issue is unique / specific to a certain output? e.g. does it do this when using PC speakers vs headphones, via HDMI audio or via integrated motherboard sound? Have you attempted to unplug and re-seat connectors - this sometimes forces windows to re-initialise the sound device and can make a difference for some.

  7. Is this issue only happening in one place in the game - i.e. is it only happening on a certain background sound clip? on a certain character or in a certain map? This is helpful as it could indicate a problem with a particular sound clip or map.

  8. Is this happening immediately when you first start the game or does it deteriorate over time while playing?

  9. Please can you set your game to the lowest config to see if this makes any difference to the stuttering - 1080p, Very Low quality & all special features on their lowest setting or disabled. Please ensure that the game has an fps limit enabled and set tot 60fps… (no vsync)… Note: this depends obviously on your hardware but its important to see if the issue is performance related.

  10. Is View Reliability History or Event Viewer on your system showing any issues that could be happening in background?

Just came back to the game after a hiatus.
Having the same issue now.

Player.log (33.0 KB)
le_graphicsmanager.ini (523 Bytes)
DxDiag.txt (76.9 KB)

Attached the 3 aforementioned files.

Added info:

As sanity checks, made sure it’s not a new issue with my system, does not happen in other games and is restricted to Last Epoch.
Also, Tried to re-enable my internal on board sound driver and used speakers instead of my headphones, and the problem occurs there too. No difference.

Event viewer shows nothing special.
Graphics have been set to lowest level as advised. Problem persists.
No special CPU/GPU/Memory overload (or even close) as the problem occurs.

The problem does not occur at all in the title screen, only after a character is loaded and is starting to move around and do things.
Started a new character, and it seems the problem occurs through different zones, with different music playing in the background.

Checked for driver upgrades.
Closed all other applications.
Verified game files on steam.

I think that concludes the list of suggestions / requests.

Really ruins immersion and makes it hard to play (well, makes it not so fun… So I don’t).
I hope this gets solved.

Welcome to the forums…

Note: For bugs & technical support issues its better to open your own thread and reference similar ones - your problem may seem similar to the OP but the cause could be different and its unlikely that your setup will be the same… and the OP has the option of closing a thread when their problem is resolved while yours may not be.

You havent really provided any specific information as to your problem other than saying “having the same issue now” so some assumptions have to be made - never a good thing when trying to debug issues like this.

Looking at the files you have provided:

  1. Your GPU is about 50% faster than the minimum (GTX 660 Ti) and about 30% slower than the recommended (1060 GPU) so, in my experience helping out here, I would recommend running the game at the very low settings irrespective of sound issues. From a performance stability perspective your settings WILL have an impact and if the system is struggling, then audio suffers… With LE in beta, you do NOT want any component to be flatlining at 100% for any length of time - GPU/CPU etc…

  2. Your GPU driver is from Dec 2021 - from a quick check, there is a newer GPU driver dated 4/25/2022. It is important to update these using a clean install.

  3. Checking your BIOS also shows that it is from 2016 - latest for your motherboard is from 2018. This may not be related specifically to the sound but as you are using integrated sound its possible and while I dont know if your mb had any specific updates, there have been security issues resolved by Bios updates since 2016.

  4. Your windows version “should” be ok, but there is an update available. There have been issues with windows hotfixes doing odd things (I even found specific hotfixes that caused problems with AMD RX 480 GPUs & Unity games) so its important to make sure that your system is fully patched and there are no failed updates etc…

  5. On the same note, the Realtek drivers you are using - I am not sure exactly what version of the HyperX headset you are using but their support pages recommend that you make sure you are using the latest audio drivers for the Realtek devices… From what i can see from your DXDIAG is that you are using the default windows audio drivers from Windows 19041 - again should be ok normally, but you are having problems so alternative Realtek provided drivers might help… Maybe even older audio drivers from your motherboard manufacturer might be worth trying.

  6. You mention you tried different audio output devices other than the headphones and different audio ports (audio plug vs USB etc)… Did you reboot between each attempt? There is a known issue with LE being unable to change default sound if you change them on Windows with the game running… Sometimes LE even struggles if you havent rebooted the system after a sound device change…

  7. Have you tried a different window mode - i.e. Fullscreen or borderless window - this may seem like an odd thing re audio, but people playing Unity based games (like LE) have found that the window mode can help with audio issues.

  8. Another thing to help isolate the issue… Try dropping the framerate limit in game to 30fps… just temporarily as a test to see if this has any impact on the sound.

  9. Have you attempted to disable music and/or sound effects to see what difference this may make? I.e. does either affect the stutter or do you hear it in the background music or in the actual player sound effects… Does the stutter go away if you disable one or the other?

  10. FYI - Your Diagnostic section of the DXDIAG is suspiciously filled with “No Data” entries… Not impossible, but its VERY unlikely that a Windows system doesnt at least have at least some entries in an event log even if they are just info/warnings… Usually you can see from these entries if there is anything else happening and even the most pristine newly installed Windows systems at least have something there… e.g. If LE has ever crashed or hang on your system (things it can and does do) , there should be logs of it there… In all my decades of windows tech support, an empty log is odd…

Tried updating everything mentioned except BIOS until now,
All graphics are at the lowest settings.
Tried changing window modes.
Frame rates dropped to 30, and even to 15 to make sure.

Disabling music or sound effects doesn’t seem to be making much difference.

I did notice 1 strange things after all these many restarts -

Sometimes, when the game starts, the problem is barely noticeable… I could say it may as well not be noticeable on these rare occasions. However, even at these instances, just playing through 1 or 2 zones causes the stutters to appear in force, and stay.

Finally, when I had those instances when they seemed to be gone/almost gone, I later try to restart the game with the same settings, and it seems the sound issues are back right on trying to play a character.
In other words, it doesn’t “go away” consistently on those same settings.

All I can think of is to try the bios issue and see it that works, but otherwise, no luck so far.

Thanks for trying to help.

Hey there…

I was going through the old bug reports and the devs did implement something in 0.8.4C that was supposed to deal with stuttering that had been reported before but obviously it hasnt entirely solved this for some…

After reading your comment about it becoming more noticeable over time, I recalled an old post with a workaround that another player said worked - seemed to work for others randomnly too… They tried this when the stuttering started:

Go into settings after you load your character, go to the Sound tab, and slide the Master Volume all the way to zero. Release the mouse. Slide it back up to wherever you want it, and exit the settings menu.

Obviously your setup isnt the same and I have no idea if this really works because I cannot test it (no stuttering on my system no matter what I do) but apparently this seemed to resolve it until they changed chars or restarted LE , but then they could just do this again to stop it… Obviously not a solution if it works but at least its a temp fix…

Another thing. Re the empty diagnostic log… Can you look in your “View Reliability History” and see if there are any errors bring reported by windows - especially anything around the time the game is running or anything directly or even indirectly related to audio.

Sorry for the long delay in replying.
Life got in the way. Then the new POE league started…

Thanks for your reply and idea, (un)fortunately, I go through all other similar bugs before posting, so I tried that strange one already.

However, this post is a good one:
I was playing again, having the same sound problem, and suddenly I noticed it was gone. I thought about what could have happened, as I didn’t change anything in game, and then it hit me:
The only change was me dropping the room temperature, but why would that affect only last epoch, and why only this way?

So I went on a small series of tests and experiments:

  1. CPU (not GPU, surprisingly) temp was indeed way higher than it should, but not high enough to mess general computer and gaming performance (including some heavy duty games).

  2. I could perfectly control the stutter - If I changed the room temperature - wait a few minutes, the expected behavior would occur/stop… And if I kept it, it never changed.

  3. Tested the fans and their reply to changing condition -
    They were slightly malfunctioning - did not respond to the temperatures they should respond to. It was almost amusing - slight issue - not enough to affect most games in a noticeable way, but sufficient for this specific problem in last epoch
    (as you have mentioned, it’s both a game in Beta, and a unity game (and as I have been following dev posts, I know performance tuning is something that still should be done).

Fixed the problem.
CPU temp dropped.
Sound stutter stopped.
And I’m sure it could help prevent a potential larger problem, should that issue have remained hidden…

Thanks for trying to help.
That specific problem was a bit unexpected for me, as the temperature was on a very specific threshold where it did not interfere with other, very demanding games.

Thanks for responding…

LE is very CPU intensive so it does demand more from a CPU than other games. Stuttering is a sign of a performance issue but I didnt link it to your CPU because your i7-7700 is the same performance as mine and I didnt link temperature throttling to the Sound stutter…

Usually temperature issues show up much easier than this and I am wondering if your system had been throttling itself in the background and you just never noticed it…

Glad you were able to fix the cooling issues and solve the problem.

Comparing it with Path Of Exile, especially heavily juiced maps in POE, I think POE is more CPU and GPU intensive than LE, which is why I was expecting such a problem to appear there as well.

But, Different games, different engines, different stages of optimization, etc…
So one can’t really draw strong conclusions.

Oh, and as to the empty logs, while I cannot think of a specific reason of the top of my head, I’m a software developer as well, and I can think of a few possibilities which may be related to it. Not that strange on my system, but thanks for pointing it out.

You may not believe it, but PoE is actually much less demanding than LE right now… Depending on settings potentially causing bottlenecks, most of the FPS spikes people are having in certain maps & situations are actually CPU related.

LE is so unoptimised right now that if you dont reign it in with settings, it can readily max out components, cause crashes and even in some edge cases require systems to be rebooted.

Thankfully the devs have committed in the last dev blog that they are focussing on performance (for the first time in a patch cycle) so we should hopefully see improvements on that end…