My Account
× My Account Forum Buy Now

Last Epoch Forums

[SOLVED] Windows 11 - Steam launch

Hello slashers :grinning: !

On windows 11, the game stay stuck on splash screen with Last epoch logo, and load…for ever. No possibilities to kill the game by task manager, need to restart the computer. Tried to reset graph’ settings, it’s the same bug. I’m on the latest Nvidia drivers (for W11). All other games works. (X4, Gim Dawn, Kingdome Come, Horizon…).

By the way, thx for this awesome game ! :grin:

Have fun !

EDIT : Retry to delete config files, made a steam check files and now it works ! :sweat_smile:

Hey there… Welcome to the forums…

You are probably the first person to post here about Win11… Thanks for posting your findings.

These are the normal set of things to do if the game freezes… Glad they still work on Win11…

Just remember LE is a beta unoptimised product so chances are you will have hassles… But if you are conservative with your settings and dont push the game too hard, you are likely to be able to play fine…

1 Like

No problems ; The last beta runs fine on my laptop (legion y540, i5 9300f, 16go, rtx 2060 6go). I play on medium settings, and laptop temperatures are ~55/60° max. It will be better near the 1.0 :sweat_smile: (i think :thinking:).

Windows 11 runs very smooth, no problems for gaming. I was a bit afraid about the first freeze but now, perfect :ok_hand:

Cheers ! :champagne::sunglasses: