[SOLVED] Missing and WrongDisplay passive points

[edit :] Solved, im not only tired but also can’t count. 8+2+10+10=30 not 20, so it’s all fine. And the rest is justa display bug

I’ve got a lv72 paladin here with 75 passive points (where it should be 72+13, as all campaign quests were done/completed, such as quest log shows).
On top of that, the passive screen shows/tells I have 77points, 22 of which in Forge Guard, but as the following screenshot shows, it looks to be a display bug?

…Any idea how to get the 10 missing points back? thanks for any answer :slight_smile:
edit :
Oh i forgot, account name is “Neyhoum”, character name is “NeyAndBigBonkyFriend”.
Possible/probably cause : respeccing? respecced the char maybe 2 or 3 times since I made it few months ago?

I have same issue. Void Knight must be 27 but it’s shown 22.

The number of points that it displays in your non-mastered passive trees is capped to 25, so that 22 under Forge Guard should be 25, but it’s only a display issue.

Also, 8+2+10+10 = 30 unless my mental arithmetic is worse than I think it is.

Also, the characters are saved on your pc, not their servers.

thanks i’m tired, 10+10+8+2=30 and im not missing any point >_> tired

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.