My Account
× My Account Forum Buy Now

Last Epoch Forums

Slow download speed in launcher

Hey, I just backed the game and am trying to download it now, however the launcher is downloading incredibly slowly. While downloading other games earlier on in the day, I was getting up to 6MB/s, but while downloading Last Epoch, I get at most 250KB/s.

I’ve allowed the launcher and patcher in my firewall, and it’s currently 4:42am as of writing this so it’s definitely not peak usage for my uni campus wifi. :joy:

Any help? I imagine I’ll get it downloaded before a response but it’ll be helpful for future reference with patches and such. Thanks in advance!

Hey @Fruitbread,

I’m having the same issue, usual download speeds are 5mb/s and I’m getting between 250kb and 1mb on the launcher

Nice to know it’s not just my PC being funky! :smile:

Sorry to hear about this!

Have you looked at our Troubleshooting Download Issues support article?

If so, having more information could be very helpful. It’s hard to offer specific advice without knowing whether you’re using, say, Windows 10, Ubuntu 18.04, or macOS Sierra.

I’m using Windows 10 and did all that I could from the troubleshooting link you sent

If only Last Epoch is affected, Flagging The Game As a Trusted Application might help.

Hello, i have the same problem here. Did everything as described here. But the download speed stays at about 100kbs. Any ideas maybe? Thank you.

Hello again, has done. Have rebooted the wireless connection and now loads at full speed.

good evening :slight_smile: i just tried to install the game and it seems that i’m suffering from the slow downloads speeds too. i’m on windows 10 pro 64 bit and tried the solutions offered in your troubleshooting download issues support article, flagged the launcher as a trusted app in the windows defender app, restartet my pc countless times, deinstalled my 3rd party anti virus programm etc. i have no issues downloading from any other sources, tested my bandwith which is fine (~100 mbps download / ~30mbps upload). max d/l speed im getting through the launcher is smth around 100 KB/s. oh yeah and ofc i dont use wifi.

best regards

//edit: hm that is odd. just now the d/l speed ramped up to around 1000 KB/s^^ still not optimal but quite ok so i guess it mysteriously solved itself for me :thinking:

//edit 2: at 55% now and d/l speed went up to 4 MB/sec so i guess i was just impatient :sweat_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.