Skills not gaining levels from item

I am using a horned staff that provides me with +1 to level of all minions skills. When I equip it I see my 3 minions skills gain a level. But once I try to actually spend a point they all loose the level again.

The skills in question are Summon skeleton, Summon Skeletal Mage and SUmmon Bone Golem.

I’ve tried relogging and unequipping and equipping the item several times.

They do, it’s the UI not updating that’s the bug. Which is also known.

That is indeed the current issue
We are investigating a solution

1 Like

at skill level 20 I take the staff off and put back on it says that 3 of my skills have a +1. I put the skill point in the first skill and the rest disappear. I have counted the 3 skills (summon Wraith, Summon Bone Golum, Summon Skeleton mage) and the visual says only 20 and 1 skill is at 21 and the other 2 are only at 20. can only apply the skill up to 1 skill before the all flashback to 20

Have you tried relogging?

Ty, that works but had to log 2 time

1 Like