[SKILL NODE] Primalist 'Maelstrom: Gathering Storm' node proc seems to stop working

With the understanding that it is only a 25% trigger chance (5/5 node spent,) it appears that the “proc on kill” effect of the Maelstrom: Gather Storm node, ceases to trigger for me after firing initially firing off in a session.

The first few kills in my first run after loggin in will see the proc take place, but after triggering once or twice, it stops for the remainder of the run. It will not trigger in subsequent runs. It does not appear to trigger again unless I log out/in and restart the character.

NOTE: Character build is Druid and runs cited skill in persistent Werebear form. The Maelstrom tree as I run my build is also further modified by the ‘Cyclone’ node, converting it to Physical damage… in case this makes a difference.

Please let me know if this is a known issue or if any additional information may prove helpful.


EDIT Also, I just noticed that, after it has stopped working, at least in this latest run, the Maelstrom stack icon is indicated for my character, even though all stacks have long since faded:


Captured a short video to show what is occurring: Twitch


In addition to that comment, I tried different node builds for Maelstrom with 3 idols (chances to trigger Maelstorm), and overall it works perfectly the first time and then it stays stuck with the icon “Maelstrom stack” staying visible (as on SolitaryCynic’s screenshot) and no Maelstrom effect triggered ever anymore.

EDIT : A few more tries, sometimes it seems to be stuck without displaying the icon too - just doesn’t trigger anymore unless I change form (then it seems to “reset” the odds).

Hope that helps!

1 Like

Unfortunately, did not see anything in the 0.7.7e notes indicative of this issue being addressed. Hoping it is resolved, but… we’ll see. :crossed_fingers:

EDIT Issue still exists, at least for me, after the 0.7.7e patch. Bummer.

I’ve just tried to reproduce this issue and haven’t been able to, but I have found a potential cause that I’ll look into.

Can both of you post a screenshot of your Maelstrom tree? In general when reporting a skill issue it’s very helpful to have a screenshot of the tree so we can try to recreate the problem exactly. Thanks!


Sorry for the late response, hope that will help anyway.

I just changed one skill back to try to use Maelstorm again, and here it is:

  • Maelstorm level 1 at this stage, only point is in the Whirlpool node
  • 4 idols are to cast Maelstorm every 5 sec
  • it worked in town, Maelstorm was launched a few times, then I started a timeline and it’s stuck again



Hey there,

Bumping this bug report since i’ve encountered the same issue.
Note that i’m also running as Werebear at all times.


Edit :
After further testing, it seemed to work normally when out of WB form, until it started bugging again :

  • the UI showed one stack of maelstrom at all times (icon at the bottom left of the toolbar)
  • there was no visual effect around the character
  • there was no spell effect associated with maelstrom (no dodge increase, no damage over time to nearby monsters)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.