Skeletal Sheath - Bone Armor after Death seal is Bugged

Its been almost a YEAR since I’ve first found this bug, this node is just not working and I don’t think it ever has worked since Death seal was added to the game. I was hoping for the promised bugfixes of 1.0 to fix this but it seems that the patch mainly served more bugs than fixes.

First there is the basic issue that this node gives a different bone armor(10% DR) than Transplant(300 armor, 12% DR that can be increased to 15%) or Summon Skeleton(40% DR) so it does not make sense if these three will stack or not since they have same name but different effects.

Then there is the fact that there is no DR or armor provided by the node at all. This can be easily tested through self bleed/poison showing that there is no reduction in damage.

Maybe it would be better to put a disclaimer on such nodes that are not working or make it so they cannot be allocated until fixed so people do not waste points on such nodes.

Cool to have bugfixes for overperforming stuff, but how about for not performing stuff ???

Was checking the forums to see if the Bone Armor augments from Transplant tree worked for other skills that can provide it (Bone Curse, Death Seal), but was surprised to find this post.

Bumping for visibility! Hopefully it gets fixed soon!

Would also be nice if the Physical node in Death Seal would change the skill tag to physical, though it might be intended to stay as necrotic.