My Account
× My Account Forum Buy Now

Last Epoch Forums

Shadow setting causing low FPS

I’ve been playing for quite some time now through several patches and I’ve noticed something that I haven’t seen mentioned anywhere. Perhaps this is because it only affect me, but at any rate: Every few hours of gameplay regardless of which zone I’m in my FPS drops to the mid 20s or so when idle. If I adjust my Shadow Quality setting my FPS will zoom up to my Vertical Sync cap of 60. Happens all the time and every time i adjust the setting it fixes the issue. I can change shadows from a lower setting to a higher one and it has the same results.
Anyone else have this issue? Or perhaps try this when you are experiencing low FPS.

Hey…

Shadow causing performance issues is a well known problem…

The developers have made many changes including a specific update to shadows some months back that seemed to make a difference…

However its still a real FPS killer… So much so that i have the shadows on their lowest possible settings for play on my old 1060 GPU.

I have never noticed a degradation over time with shadows - for me its just an immediate loss of fps that is simply not worth it visually.

A note about vsync tho… it doesnt work as well as the framerate limiting option - yes, technically it should do the same thing by limiting frames to your monito Hz but there is something in the way that LE is handling it right now that seems to cause problems for some… I’d recommend just flipping it to the framerate limiting instead to see if that makes things more stable in terms of fps fluctuation and overall game stability. A side benefit of this framerate limit option is that you can adjust it so that you can control your GPU usage and therefore your GPU temps etc… I have found that a change of just 5 fps can mean 15% less GPU usage.

Thanks for the response ill try switching to limiting frames to 60 instead next time i get some game time. Ill update after trying that out.

The framerate limiting didn’t help, and caused a lot of screen tearing without the vsync on. I tried to limit it at 59fps as well and still screen tearing (monitor refresh rate 60hz). Still having same issue although my last gaming session on this newest patch it does seem to be happening much much more often, every 15 minutes or so I’ll drop from 50-60fps down to 22-30 until i adjust the shadow setting. I did discover even enabling the ‘detailed shadows’ option increases the frame rate albeit temporarily.

Can you post your dxdiag and in-game graphics settings ini file?

With that info I may be able to gauge what kinds of performance you should realistically be able to get with LE in its current beta unoptimised state… and recommend something (if possible) to improve your experience.

For comparison…

  • I use a 1060 3gb/i5-7500/16gb/NVME/Win10 desktop system.

  • I play on 1080p, 55-60fps framerate limited, all in-game settings on very low or disabled. Very stable, GPU usage only occassionally maxes out (like opening inventory / stash in town) and averages 60-70% usage during actual play. FPS averages between 40-60fps with ocassional dips in busy hectic moments into the 30s or late 20s for a second or two.

  • My hardware is capable of around 100-105 fps with the same settings but it gets very unstable, my GPU usage is maxed out most of the time and fps spikes can be huge - up to 40fps drops at a time… For these reasons I do not run the game at more than 60fps or any higher graphics settings in-game.

DxDiag.txt (101.2 KB)

Had trouble locating the graphics settings ini file, I dont have an ‘app data’ folder in my username folder.

I play LE in 1080 and the graphics settings don’t seem to affect whether or not my issue occurs. I’ll play some more with Very Low graphics settings and make sure it still happens.

(update) even with very low graphics settings this happens, it doesnt matter if i’m very high or very low its the shadows causing an issue. When i notice I’m idle and getting 40 or so fps I can change the shadow setting from very low to very high and it will make my fps go back to 55-60 for a few zones.

Hey…

You do have an appdata folder - its just hidden by default and you have to allow your user to view hidden files/folders..

Thanks for the dxdiag in the meantime.

  • Make sure to verify the steam game files to ensure that you dont have a corrupted install.

  • your OS could use a patch or two.

  • your graphics card driver is over a year old - while I dont usually recommend the latest bleeding edge one, a year old is too old for a graphics driver - especially when trying to play a new beta game like LE that has graphics issues… Try a new GPU driver - it could make a big difference.

  • Expectation wise, your cpu is about 20% slower than mine and your graphics card is about 50% faster so I figure your performance should be around what I am getting… Considering LEs current unoptimised state and the fact that it has CPU bound moments, I would think that you should be able to get a stable (i.e. not crashing etc) 65fps (maybe 70).

  • Please check your windows driver settings and make sure that you are not overwriting any setting that hte game is trying to make - i.e. keep things on default or let the game decide settings.

  • What is your E drive doing? Its meant to be a 1TB WD but its reporting 0.3GB? Thats very odd.

  • The diagnostic section at the end of your dxdiag file contains a list of the recent errors on your machine… There are lots of update problems and quite a few memory related issues (RADAR_PRE_LEAK_64 etc)… I would run System File checker and then try a Windows Update to make sure everything is working fine… I would also check your windows error logs (nothing to do with LE) to see if your system is warning about any problems that need fixing…

  • Also… make sure not to run any other applications or overlays while testing LE… Even if it seems irrelevant, just dont run it or disable it temporarily.