My Account
× My Account Forum Buy Now

Last Epoch Forums

Ruins of Welryn blocked

I’m already in chapter 5 but I just wanted to do the ‘A Study in Time’ quest and I did not unlock the waypoint for Ruins of Welryn before. So I tried going to Welryn Undercity to go break 3 of the Soul Repository again but the door is still blocked and I need to get to Ruins of Welryn to get to Ruined College.

When I forget to unlock this waypoint and need to go back later, I usually go by the Cultist Camp. Could you try that?

Ohh lol I could see a path, I had tunnel vision. Thank you so much for your help.

1 Like

i’m having the same problem and there’s no path from the Cultist Camp nor can i complete the requests over again to open or remove the ghost to get access to the college. Please fix this because its not allowing a chance to obtain a skill point. I’m level 80 and i was checking for missing skill points and this is the only one I’m missing and I"m pretty sure there more people with the same problem.

From the Cultist Camp, go North and take the first path. In Welryn, either head North to the Library, or first East to unlock the portal.

Like i said there’s no way to pass the thing infront of the door inorder to get to the library I already tried SEVERAL times this is what i can’t get past https://imgur.com/a/2MOgimk i completed the task a long time ago but turned the computer off or left the realm or lost the portal back to the realm

You don’t need to pass there.
As I said - and as I often do - go in the Cultist Camp, go North, take the first entrance to another zone, then head North and a bit East, you’ll find the entrance.
The gate you show me is not on the right map.

Now what Mr. Knowitall https://imgur.com/a/3U1Ne5q

Have you got the key from the quest giver in the Imperial era & unlocked the door there? I can’t tell from the pic as it doesn’t have the quest info on it.

That’s a different thing. You were talking about the gate, I responded about the gate. I’m happy to see you made it there.
To do this quest, you must first talk to Ansella in the Outcast camp. Then, you’ll go at that same place in the Imperial Era. There, you will enter and find a closed door. At that moment you will be told to go to the Ruined Era.

If I annoyed you while trying to help, I’m sorry. I won’t bother you again by trying to help. Now you have all elements, you should be fine.