Rollback after boss from monolith timeline lvl 66

I got rollbacked after trying the final quest boss from monolith timeline lvl 66 (I ran away from the boss and teleported out, tried to join a party with a friend)
My character got rollbacked to some timepoint during the same session (the end of the previous monolith timeline) and all level and item progress were also rollbacked.
Is there any possibility of restoring the lost progress? I lost several good item upgrades…

Player.log (2.5 MB)
Player-prev.log (1.4 MB)


Well, that sucks.

Server hotfix 0.9f2 addressed some causes of rollback but looks like there are some left.

An EhG helper put this on the Discord


If you are experiencing any Log-in, Lag, Disconnect or Rollback issues please report this to our Support Team here :

Pick ‘Technical Issues’ from the drop down and provide your:

  • Display Name
  • Character Name
  • Date & Time you noticed the loss (with your time zone or UTC)
  • What type of data was lost
  • How much gameplay time was lost

Thank you! <:Bee:889980256331628564>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.