My Account
× My Account Forum Buy Now

Last Epoch Forums

Reddit posts removal

Not sure where to post this issue, but on the subreddit whenever I try to make a post I am instantly given a post removal notification for some reason. Could I maybe get this looked at, so I am able to post my builds on there.

Looking into it now!

EDIT: I do not see anything that would be restricting your posts. I notice there are builds and similar posts going up quite regularly. Can you post anything at all?

Hey thanks for the prompt response, Aluxaeterna :slight_smile: It seems the issue is only isolated to LE Subreddit, tried posting when I wasn’t joined and joined back tried again. Also tried it in another game’s subreddit, but it worked there. I am not sure either :confused:

Hello again,

I was messing around with some settings and might have found out why. Try making a post and let me know!

1 Like

Post was made with no issues, thanks Aluxaeterna!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.