My Account
× My Account Forum Buy Now

Last Epoch Forums

Ravaging Stance

Operating System: Windows 10

Detailed description: Losing life, but not doing damage.

What were you doing at the time?

How consistently does this happen?

Your system information:

Your log file:

This is a known issue and will be fixed in the next patch.

Apologies for the inconvenience!

Hi just to inform that ravaging stance appears to still not do damage after patch. I tried it at the dummies in council chambers.

Thanks for the update, and sorry for not responding sooner.

We’ll look into this one again.

I’ve been testing this but I’m not able to reproduce it.

Would you mind telling me which uniques (if any) your character has equipped, and give us a screenshot of your Sentinel and Void Knight passive windows? Might help us track it down.

Sorry missed this.

I deleted that character already.

I happened to have a naked character with no passives and i reset all the skills to test. It did not work too. Both at arena and the dummies.

Hope that helped!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.