Random Instances Where Items Can't Be Picked Up

Title. Numerous instances in which I’ve been unable to pick up items after playing for a short while and seems to be triggered by something but I’m not sure what. Originally I thought it was because I would alt-tab out of the game to use my other monitor and multitask but most recently I completed a prophecy while in a dungeon and right after it dropped those items the bug triggered again and I couldn’t pick them up. Only solution is to exit the client and restart it. No consistency to it either, played this weekend doing all of these things without issue for a couple hours. It’s happened variously throughout the campaign and only once in the monoliths so far and now the dungeon. Uninstall and reinstalled all files after having to close tonight. Guess I’ll update if that fixes anything.

Just to be clear since I’ve done a search on this, the loot wasn’t filtered, tool tips on and off made no difference. Names were on screen. When it happens again I’ll take a video of it to include.

2 Likes

having the same issue. disabling filter or alt z doesn’t help. i can clearly see a unique dropped, but there’s nothing to pick up.

1 Like

Same for me today. Random monolith instances where I can’t pick up loot, with or without loot filter. Same if I drop something from my bag, can’t pick it back up… ;/

Same here after killing Julra, already tried everything, disabling filter and alt z, and changing resolution and refocusing loot, taking filter off etc etc… There’s unique and exalted items where Julra died (I can see the lights and unique logo in minimap), but there’s prophecy loot few meters aside that I can see for some reason.

I don’t know if it matters, but I’m currently having the same problem on Monolith 100

This still occurs. Finished a echo and a lot of items dropped, but couldnt pick anything up. I though it was my filter but disabling it still didnt show the items. toggling the labels with alt+z also didn’t do anything. The items were laying on the ground, but the labels wouldnt show up.

I noticed that I am unable to click on the items while I figth monster/boss with Ward mechanic, until the monster dies.

1 Like

Confirm that it’s still occurs.
I dropped my item to check item-filter, no label floating, can’t pick-up.
Tried everything, close and open item filter/ground item tooltips, ctrl-alt-delete and then cancel.
nothing work.
Lose it just like that, freshly crafted :rage: :rage: :rage:

Sane problem, started with monoliths, and now it happens every second monolith. Happened 6 times already.

Same here.

Happened to me in dungeon, boss dropped loot, cannot pick up anything.

On the next run instance froze in a loading screen.

Early in a cycle a good reason to logout.

EDIT: my system clock was quite skewed, can that be a reason?