My Account
× My Account Forum Buy Now

Last Epoch Forums


I’m stack on this part of main quest, getting crashes on some point in next instance after ‘Titan’s Canyon’. Tried already 4 times with different roads.

Same Problem here.

1 Like

I’ve crashed 5 times now in this zone, all at the same spot. Cannot progress at all.

Turn all of your graphics to very low (Master quality: Very low) and disable everything in advanced graphics. That helped fix the crash for me and other people.

Hi everyone,

We’ve made a change which may mitigate this in 0.7.0b. Please try again!

If you’re still having issues, you can help us find the issue by uploading your log file and your system information. A potential workaround is to go into Graphics Settings and set Master Quality to Very Low.

Let us know how it goes!

Still crashing for me; tried 4 times. Attaching files.

output_log.txt (82.0 KB)
DxDiag_05032019.txt (98.3 KB)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.