Problem with Turkish capital letter "İ" on game interface

Hello LE Team ;

Game is running in English yet i’m still seeing turkish letter “İ” which is a special letter on Turkish alphabet for capital “i”.
If it was just that i would be ok with it but it shows as a square on item name’s etc.
I’m not sure it’s a problem on my end but if it’s not could we please get a fix for this ?

You can see an example screenshot below :


I can replicate this (after enabling support for tr_TR.UTF-8) if I set the game’s launch command to LANG=tr_TR.UTF-8 %command% (Linux-based OS). It’s actually the letter i being incorrectly capitalised (for non-Turkish text), which suggests that the devs failed to consider this case, most likely due to being unaware of it.

I can replicate it fairly easily with a short program:

#include <unicode/uchar.h>
#include <unicode/ustdio.h>
#include <unicode/ustring.h>

#define STRLEN 256

int main(int argc, char **argv) {
  if (argc < 2)
    return 2;
  UChar str[STRLEN] = u"", str2[STRLEN] = u"";
  u_unescape(argv[1], str, STRLEN);
  UErrorCode err = U_ZERO_ERROR;
  u_strFromUTF8(str, STRLEN, NULL, argv[1], -1, &err);
  u_strToUpper(str2, STRLEN, str, STRLEN, NULL, &err);
  u_printf("%S\n", str2);
  return 0;

This was compiled locally with gcc -Og test.c -o test -licuuc -licuio.

My default locale settings:

$ env | grep -e '^LC' -e '^LANG'


$ LANG=C.UTF-8 ./test iı
$ LANG=tr_TR.UTF-8 ./test iı
$ LC_MESSAGES=tr_TR.UTF-8 ./test iı

Basically, you’ll need to override the locale somehow. On a Linux-based system, it should be enough to set the launch command to LC_MESSAGES=C.UTF-8 %command% -force-vulkan (which also deals with some rendering errors); I don’t know how to do the equivalent on Windows.

To fix this, it appears to me that the developers will need to set the locale (or that part which affects case conversion) to something appropriate for the selected language. (If they set the whole locale, date formats may become a problem: consider en_US vs. most of the rest of us.)

Thanks for the reply and answer , wish there could be something i could do to fix this but nothing helps atm.

Hopefully one day devs can do something to fix this issue.There were a lot of lines about localization on the 1.0.1 patch and i was hopefull but no fix atm :frowning:

Having the same issue here. OS is Windows 11 English yet my KB language is Turkish Q. Please make a fix as it is really annoying.

What do we need to do for them to hear our voices? This is really annoying.

I tried changing my keyboard layout to EN (Operating System is already EN) restarted the game but nothing changed! Please make a fix soon as this is really annoying.

To clarify Turkish has 2 letters for what you use in English “I”. They are “i” with a “dot”, and “ı” without a “dot”. So we have:

  • “I” for capital and “ı” for smaller letter
  • “İ” for capital and “i” for smaller letter

So in order to convert it to English properly you need to use the first example ( I ) for “CAPITAL” letters and use the second line shown above (i) for “smaller” letters. It’s that simple.

Just realize seeing a square instead of a letter is not the worst thing , stash filters that includes “i” letter in them are not working at all because of this reason.We can’t filter correctly because of this …

Can we please get a fix for this , i did some research online and saw complaints from couple years ago.How is this still not fixed is beyond me.

1 Like

same problem and its annoying cmon Devoloper team fix this pls

Any update?

DEVs please address this issue. The game looks really awful at this state. Even opening something as simple as the Map or any other standard screen within the game, or even looking at drops breaks all immersion. There are square symbols everywhere. This issue is not something that can be low priority. I don’t know how many copies you sold in this region but all of them are pretty much facing these symbols everywhere in the game. All we want from you is to display English fonts in the English alphabet! Doesn’t that sound like something you had to do before releasing the game? Again, please, any devs reading this tell us something… anything. Personally I just want to know it’s noticed and in the works… hopefully will be addressed soon.

But if you stay silent that really is a kick to the face to all of us here.

1 Like

it still continues problem…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.