Problem accessing Lake Liath


I’m on the quest “Liath and Thema (Head west through Lake Liath)” and i got teleported to the Lake Liath zone, but I had to log out. When I’ve logged in again, I’m on the End of Time zone, but the waypoint to Lake Liath is grayed and I’m stucked. I’ve tried talking to the NPC near Rahyeh, but nothing triggers the teleport to Lake Liath. Is it possible to abandon the quest and take it again ?

Here is the log : Player-prev.log (26.2 KB)

PS : I tried reloading the games several times, without effect.

I’m not certain what you mean by “NPC near Rahyeh”. Have you tried talking to Harbard the Ferryman in Deep Harbor? Could you screenshot your quest tracker on the right side of the screen?

I also had this problem. The game crashed in the area after Lake Liath before I had grabbed any map points on this side.

Thankfully, you reminding me to talk to Harbard again solved it, but there is no in-game indicator whatsoever other than “Ready?” in Harbard’s dialogue options.

Thank you!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.