Possible bug with Wengari MoF end of 2nd quest echo

Problem: I did the quest echo above and I hit ‘portal’ when I completed it, but the portal somehow managed to get embedded into the background and I couldn’t interact with either the portal and interacting with where the horn was just says it’s not there.

I logged out, lost two echo levels shakes fist, and tried it again. When I reached the end, it was saying “The sacked alter has no signs of the blessed horn”, and the horn isn’t there. I can’t portal out and I can’t continue in any meaningful way.

I need help here as I’m quite literally stuck on this MoF branch if I can’t find a way around this bug since I can’t continue past this quest echo. The only way to “continue” is to leave and log back in, but if I do that it repeats the cycle as mentioned previous.

I have a screenshot too but I don’t remember how to post it here. It’s not letting me copy .jpg files. Let me know if you need to see it.

Yeah, if the portal spawns in an unreachable place, you can move somewhere else & press T for another portal.

Most people upload images to other sites (I use imgur.com) & link them.

No, it’s still bugged. I went back, there is no quest marker. I cleared everything, nothing happened. I portalled out, says I lost two echoes. I even rebooted the computer, did a virus check, cleared cookies, hoping it would help, nadda.

Screenshot below. Notice how there’s no quest anymore. This is where I think the problem is, is because I did finish it before, now something seems to be stuck and I can’t move forward.


With the new patch you should see changes in your Monolith Quest State. Is this still an issue?

Let me look into it and I’ll get back to you. I haven’t been around in the last little while. I will try to get an answer today.

Checked, exact same as before. When I started the quest there were no quest markers and was acting as if the quest wasn’t there and/or was done. When I reached the end, the horn wasn’t there. No options otherwise, no portal, etc. TP out, says I’m back two echoes.

Have you tried getting steam to verify the files?

Not using Stream. My guess is when the game uploaded v0.8.1 the devs were hoping something similar happened (see Stanzwar’s comment).

If there’s another way to update the files though I’m open to suggestions.

Note: the issue still exists. I will test it again in 0.9, see if that helps anything. If you want more info/data/testing just ask, but as it’s been almost two months and no follow-up I’ll leave the bug and the character on standby in case you guys need as otherwise it’s not playable in that timeline.

Have you tried to reset this specific monolith yet?