My Account
× My Account Forum Buy Now

Last Epoch Forums

Poor performance in The Immortal Summit

Hi,

I’ve had so far great experience in terms of permormance of the game. And suddenly when I entered The Immortal Summit it turned into a slideshow (5 fps all the time).

I run on High settings. My pc config:

  • NVIDIA GeForce GTX 1660 Ti
  • driver version 472.12
  • i7-9750H CPU @ 2.6 GHz
  • 16 gb ram

Seems like the problem is related to trying to show this loooong way down that’s below this location.

Hey… Welcome to the forums…

LE is in beta and is generally unoptimised so things like this do happen - especially if players dont take this into account and dont take a conservative approach with settings…

However, there might also be something specific to your setup that could be causing this… Or there could be a particular setup/skill that makes this happen more obviously. And yes, certain maps - especially those with special effects or longer views (e.g. cliff tops) tend to cause fps drops… especially on Higher settings… but again, this is very settings & resolution dependant.

Dropping to 5fps is however very unusual - even in very busy play moments… Unless of course you are trying to run the game in 4k on your 1660 at High settings - thats almost guaranteed to cause single digit fps.

Please can you attach the following files to help the devs see what the possible causes could be.

  • your player.log - the games debug file
  • your le_graphicsmanager.ini - the games setting file
  • the output from a dxdiag report - a snapshot of your hardware/drivers.

Useful files - Last Epoch Support Hub

Thanks

Don’t take me wrong, I’m not complaining. I’ve had so far great experience with the game and loving it.

That’s why when I entered this location and it was literally unplayable I wanted to share, so you can fix it and it won’t happen for other players.

For sure it’s not a skill or even number of enemies, as it happens when I just stand on a clear map, especially on some bridges when this long gap is visible. But not only, as in some places, even when I see only the floor, it still slows down a lot. And in some other places of the map it’s fine, so it’s certainly something specific to some parts of the map. I plan on high settings with 1080p resolution, so nothing too fancy.

I’ll check this again today in the evening and attach mentioned files if it happens again.

Thanks!

Thats fine… and thanks for including more specific information. Please dont forget about attaching the other files.

I feel its important to note that if this were a general problem then the forums would be flooded with users having the same issue so its critical (and logical) to try and see exactly what is happening specifically for you… I personally just loaded up the map and have zero issues… maybe a few fps drops when overlooking an open area, but definitely not dropping down to 5fps…

There have been plenty of examples where certain maps have caused problems… but there have also been plenty of instances where it turns out a user was using an old GPU driver or some of their game files were corrupted and loading into a particular map caused a problem for them every time but not for anyone else…

The key here is to gather enough info so that others can try and replicate the problem… If the devs cannot replicate it, it becomes really hard for them to trace the cause and fix it.

It would be useful if you could also do the normal troubleshooting steps:

  1. Make sure your OS is patched and there are no failed or awaiting permission updates.
  2. Make sure your GPU driver is recent - last 2-3 months should be ok,
  3. Verify the game files - very important anytime the game is doing something odd
  4. Temporarily do not run any other application while testing LE… doesnt matter how irrelevant you might think it is, just temporarily dont run anything.
  5. As a test, set your in-game settings to very low, all special features disabled (shadows, grass, AA) @ 1080p with 60fps framerate limit enabled (very important). See if you get the same massive fps drop in the map… If you dont get the fps drop, then it could be something specific to a particular setting that affects that particular map on your hardware/driver.

I’ve checked and it still happens. I have nothing else running. Tried to lower max fps to 60 but it didn’t change anything. Have the most recent GPU driver. Here’s logs:

Player.log (61.3 KB)
le_graphicsmanager.ini (469 Bytes)
DxDiag.txt (122.9 KB)

Ok…

A few things to note from the information you have provided:

  1. The player.log is showing a repeated error NullReferenceException: Object reference not set to an instance of an object. at DestroyOnActorDeath.OnDestroy () [0x00000] - the devs might be able to trace the cause of this - I am not a unity developer so I cannot say if this has any bearing on the FPS drop you are experiencing but its noteworthy as the only obvious error in the logs that is not normal - i.e. its not a normal debug message I am used to seeing in logs. There are no graphic specific error messages that I can see otherwise.

  2. You are using a laptop which adds complexity wrt graphics cards & laptops automatic changing of performance profiles in favour of power saving etc… I would recommend that you set the last epoch executable to use the GTX 1660 Ti (Max-q) GPU exclusively - you can do this in either the Nvidia driver or in Windows Graphics Advanced settings… This is a known solution for some strange performance issues that others (using Laptops) have had trying to play LE.

  3. Do not attempt to play LE with your laptop set to any other than high performance mode… You do not want the laptop to be dynamically changing GPU clock speeds etc whil playing - it should be fixed - and not on battery saving mode.

  4. Some users have had odd FPS issues that seem to be related to Screen Mode… I would recommend that you toggle to other modes and see if it makes a difference - e.g. fullscreen vs windowed etc.

  5. According to Userbenchmarks the max-q variant of your graphics card has similar performance to a 1060 desktop GPU. With the game being in beta and unoptimised, your settings - especially combined your framerate limits - are unrealistic in my experience and likely to cause very strange & unexplained performance & stability issues. If you do not restrict LE to a realistic level, then it will attempt to take as much of your system resources as possible and max out your GPU as much as it can… I use a 1060 desktop GPU and although I can run the game at 100+fps on low to medium settings, if I do so, my GPU usage is maxed out 99% of the time and the game gets very unstable and I experience huge fps drops / stutters and other odd issues while playing - sometimes for no apparent reason like standing in a map doing nothing. Your 140fps limit - imho is too high - is unlikely to be limiting the game in any way especially at High quality settings - which could mean that your GPU is being maxed out generally and the moment you load into a map that needs more GPU resource (like the ones with long views), its struggling - which translates into an FPS spike… Without monitoring your system CPU/GPU/Memory usage and doing proper testing at the lowest settings, its hard to guess at this, but what I am describing is a KNOWN issue with LE right now… if the game were not full of debug code & had been optimised, then I would expect more of it performance wise but right now imho, for your hardware, your settings are potentially too high. For stability sake, and based on your hardware, I recommend an FPS limit at High settings @ 1080p of around 75fps. More if you drop the quality. You may have to monitor your GPU usage to find a more approrpirate fps limit & quality setting that leaves your GPU some headroom for busy moments in play.

  6. Verify that your Nvidia driver level configurations are not overriding anything the game is trying to set.

  7. Can you confirm you verifed the game files? This is very important.

  8. Your windows could be updated to version 19043 - this is unlikely to be related to the specific LE issue but its recommended.

  9. Your dxdiag diagnostic section is reporting quite a few errors - I dont think that they are directly related to the issues with LE but you might want to deal with them… I would “View Reliability History” on your system to find out more information - Things crashing are -

    • DellInc.AlienwareCommandCenter_5.3.2.0_x64__htrsf667h5kn2 - this one could affect anything running on your system… Including how your laptop is handing graphic performance.
    • There is some problem with App execution aliases that you might need to check. This is not normal.
    • Edufox is crashing regularly…

Hello, I have encountered the same issue with Immortal Summit. I have played through the zone twice and had the exact same experience.

My game performs very smoothly in all other areas, but whenever I first enter Immortal Summit my FPS drops considerably. Once arriving at the waypoint, restarting the game and returning to the ma[p seems to fix the issue, although by then the zone is complete. I haven’t tried running back through the zone to see if there is a point where the framerate drops.

It seems to be something to do with how it’s loading my processors, I notice that the CPU and GPU load actually decreases upon entering the zone.

Hi… Welcome to the forums…

Please can you post your files (player.log, le_graphicsmanager.ini and dxdiag output)… There were distinct errors and system specific things that the other user mentioned… By comparing yours it may help pinpoint a possible cause - especially if you are having similar messages/logs/errors.

(side note: I am assuming you have done the usual: GPU driver updates/ OS updates/ Game file verification / Settings testing)…

For the record: same issue, on two different characters.
Big lag in Immortal Summit while all the other zones are fine.
Dropping quality doesn’t help. Leaving the zone and reloading the game does help, feels like some kind of memory leak in this specific area.
Player.log (122.8 KB)

1 Like

Hey…

Your player.log is showing additional error messages to the OP. Specificially related to the Particle system - i.e. special effects on skills / environmental lightning etc… This has been an issue for other maps / skills that were fixed in previous game patches so it could be something similar happening now… but the exact cause needs to be figured out so that the devs can replicated the problem - without being able to replicate it, it becomes VERY hard for them to fix it.

Did you attempt any of the default things to try?

  • GPU Driver installation (Clean/safe mode - not just an upgrade)
  • OS patches all up to date and nothing failed?
  • Steam game file verification?
  • Not running anything else while testing - including graphic overlays (Steam) etc… Just dont run anything while testing - doesnt matter how irrelevant you might think it is.
  • Testing the same area on the lowest stable settings? i.e. 1080p, very low quality with all special effects disabled (no grass, aa etc). It is important to test at this level because it can point to a specific setting that is the culprit - just going from High to Medium quality will not help test anything.
  • Do you have any GPU driver based overrides - like AA or anisotropic filtering etc - active… If you do, try toggling it to see if that is what is affecting things.
  • Monitoring your GPU / CPU processes to see if there is anything odd happening in terms of clock speeds / temperatures / usage levels.