Playing Last Epoch on an ultrabook laptop (aka the true masochist mode)

I’ve just spent the past two weeks running through most of Last Epoch on an ultrabook. This includes all of the main campaign, parts of the Monolith, and with some Arena on the side. The question I’m going to answer in this post is: how was the performance? And the TLDR answer is: not great, but still significantly better than I anticipated. Let me briefly elaborate on my experience.

I’ve been playing the game on a 13.5 inch Surface Laptop 3 with an Intel i5-1035G7 processor, 8 gigs of RAM, and a 256 gig SSD. The only really notable feature here is the processor. Intel’s “Ice Lake” processors carry noticeably faster integrated graphics chips than their older mobile processors. In terms of AAA-gaming, this is a roundabout way of saying that the graphics performance sucks hard, but not as much as it used to do. Think low-end desktop GPU from a few years back. Some general benchmarks for a system similar to mine can be found here for reference:

The above is for an i7 with 16 gigs of RAM, but the only item that has any real bearing on performance in this context is the GPU, which is identical to mine.

I have the game set to render at an internal resolution of 1128x752 and with all other graphical settings on Very Low. Of particular note here is that the Surface laptops feature somewhat unusual displays. The pixel resolution is 2256x1504, yielding an aspect ratio of 3:2. The display is really the main selling point for me, as I find the 3:2 aspect ratio far superior for everyday use than the standard widescreen format. But it’s not exactly a conventional setup for modern gaming. On the rare occasion that I’ve tried to game on this potato before, I’ve usually aimed for half the native resolution in order to reduce the GPU load while still maintaining the proper aspect ratio. With Last Epoch, the upscaling from 1128x752 unfortunately looks pretty awful, so if you’re going to try this at home you may want to consider some non-divisible resolutions as well. For example, in my case the UI looks noticeably sharper at 1024x768 than at 1128x752, despite the lower pixel count. But I can live with that for science.

I usually play with the FPS limiter set to 30, even though I can technically push the frame rate about twice as high. For reference, with an unlocked frame rate I get ~55 FPS in the End of Time. The problem is that, like any other modern ultrabook, the system will throttle pretty quickly under heavy load. In my case, the throttling eventually caused the FPS to drop from the 50s all the way down into the 20s. Then, once the heat and power draw reached more sustainable levels, the FPS would slowly rise towards the 50s again. This whole boost and throttle routine also seemed to make the game’s sound stutter, so I ultimately decided to impose a 30 FPS cap in order to prevent the system from breaching its own thermal design point.

(As a side-note: if you’re trying to run the game on a modern ultrabook, you may also want to consider disabling the turbo boost entirely through some third-party program like ThrottleStop, since you’ll be at essentially zero risk of maxing out the CPU anyways. When running through the Monolith I hardly ever saw CPU loads above 40%, while the GPU could hit 100% at a moment’s notice. In other words, you will max out the GPU long before you max out the CPU.)

I’ve generally found the 30 FPS cap to hold up pretty well, but with one major caveat. Last Epoch makes extensive use of motion blur, particularly for spell effects. If an object with motion blur appears on screen, the GPU will immediately hit 100% utilization and tank the frame rate, sometimes going as low as ~15 FPS. I tried dropping the resolution to 800x600 in the hopes that it would be sufficient to maintain a stable 30 FPS throughout. But all it really accomplishes is that you’ll now be playing the worst case scenarios at ~20 FPS and 800x600 instead of at ~15 FPS and 1128x752 (although I suppose an added benefit of 800x600 is that it sort of makes the game look like Diablo 2). The motion blur toggle in the in-game graphics settings would make this situation easy to avoid, had it actually worked. But until that particular item gets fixed by EHG, your only recourse is really to kill everything on screen as quickly as possible, and preferably before they have the chance to use any skills.

Most ultrabooks are going to be well below the official minimum spec for Last Epoch, and so I don’t recommend anyone to play the game on anything but a properly specced desktop. If you have a similar laptop spec to mine, you can expect 30 FPS on a good day, but with some pretty severe FPS drops on a bad day. While I do believe these drops should be mostly avoidable once EHG fixes the motion blur toggle, it’s obviously difficult to say with certainty until we can try it out. Worth noting is also that the FPS limiter is your friend. If you’re playing on a modern ultrabook, letting the frame rate soar is inevitably going to cause the system to throttle and leave you with lower frame rates than had you simply imposed a sensible cap from the outset. All said I was pleasantly surprised by the performance, but perhaps mostly because I didn’t really expect to be able to run the game on an ultrabook at all.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.