Optimize launch and shutdown please

Yeah yeah before anyone says, i know its beta. But it BADLY needs to be optimized. It literally takes ~3 mins for my pee-c to unfreeze and start working again after closing the game, and I don’t have a potato either in case someone suggests thats the reason. No other games do this, and ive got a lot of heavy hitters like Doom Eternal etc etc

1 Like

While the game does need (& will receive) on-going optimisation, and improved load times is always a good thing. I don’t have any issues with quitting the game taking much time. I did upgrade my pc this year, but it’s not a top-notch set up & LE is only on a normal SSD (ie, not an nvme job).

You list of heavy hitters are post release fully optimized games.

This is beta. Optimization is a known issue. They work (and have success) every patch making it better.

They have even hinted at stuff in the works behind the scene that will make it dramatically better in the future

I didnt see anything about optimization in the update timeline, maybe for now ill just use an app killer?

That would be “performance improvements” at the bottom.

Hey… Cant say I have a similar issue… used normal SSD and now an NVME drive and its a few seconds at most for shutdown and launch. Obviously as everyone else has said, optimisation still to happen, but 3min is very long imho.

One thing I will say, is that if you are running it through Steam. If its using Steam overlay and the online savegame sync (especially) then I have experienced annoying delays shutting down LE (and lots of other games). In this instance 3 minutes is not unheard of and sometimes it has even hung for me to the point where I have to whip out taskmanager to kill it. I dont use it (Overlay or online save sync) anymore for any games.

I’m experiencing a huge network load when playing LE.

For example if I stream Netflix or Prime on my second screen, everytime a new episode starts and buffers, the game stutters and freezes as well.

The stutters are synchronised and only happen when I stream or download something. I would not have expected this behaviour since the game is running offline. Where does this correlation come from?

Anybody else also experiencing this?

As for the launch and shutdown of the game, both runs fine without issues. When I tab out during loading screen I get a “programm stopped responding” (don’t know how this message looks like on an english system) with the option to wait or close. But waiting works everytime and after 2s the game is back again.

And I’m playing in a potato. :blush:

Streaming video requires quite a bit of processing power for decompression of the video codec (and staying ahead of the buffer) especially on HD or higher quality streams. So if you say you are using a “potato” then I would monitor the CPU usage when you start the streams/buffering… This in turn would then hiccup anything else CPU intensive on your system - definitely LE. Depending on your setup, it could also be trying to use your GPU for the video processing - which again, could then hiccup LE.

This same effect is seen if you try downloads that do decompression on the fly… like Steam game updates or windows patches… That can serious nail an older/slower CPU.

An easy way to see if LE is actually using network traffic (should not be) is to monitor your network with nothing else running… pretty sure its the other things you are using on your system at the same time though…

Alt-tab… that could be any number of things - your description says that nothing is breaking, its just struggling to swap things around on your system and thats why you have to wait - again, “potato syndrome” could mean that it could be anything causing this… memory/cpu/harddrive swapping out… any number of things really.

Edit: if you are using a slower harddrive (mechanical) or even a very full drive, then this could cause your issues… Not enough memory and swap file thrashing can also cause temporary performance issues that show up in similar ways to what you are describing…


Well i got no problems, game loads and shuts down fast.

Intact performance has increased for me, ancient forest fight used to be a nightmare to get through and certainly no shutdown issues. Now I hear the AAA released Cyberpunk has a few issues

you may want to try disabling hardware acceleration in your browser. having it enabled will cause your browser to use your GPU and that could be what’s causing the stuttering.

1 Like

Yip. Thats the detail behind my “GPU for video processing” comment. But it can potentially cause another problem by passing the processing back to the already loaded CPU… Catch 22 if you are using a potato… :wink:

1 Like

that’s true, it’s a bit of a double edged sword. i’ve had some success with it in the past with this and other games.

one thing i’ve found that makes a huge difference is that if i’m watching a twitch stream with a very spammy chat that uses a lot of gif emotes, using a third party plugin that replaces the chat (chatterino in my case, but there are others) helps a lot. the native twitch chat is just awful at displaying stuff like that without killing my computer. just thought i’d mention it, even though the topic isn’t necessarily about twitch. just another option for people with performance issues to consider.

1 Like

Thanks @VapingNeckbeard and @vapourfire. I’ll defenitely look into this. Sounds very reasonable. I didn’t draw this connection obviously :slight_smile:

my 2 cents, i had a really old potatoe pc just bought a new i5 midraneg pc.
omg the difference.
as people have said i had a old ide hard drive new c has a ssd hd. plus huge improvement on my on cpu and 12gm f ram versus 4gm on my old pc
that being said.
several issues some above mentioned as well.
dont knwo your pc specs.
having 12gm of ram is essential having fast enough cpu is essential.
even with 12gb of ram to play hulu netflix youtube music etc my virtual ram is set at 10gb. this help immensely.
also put everything on very low in the game reduce your reolution to 800 by 600 with all the other programs you have running outside last epoch. if ity runs fine then try upping the in game reslotion till you have issues
also try reducing yer windows desktop resolution max resolution on a pc takes alot of gpu power also.
hope this helps

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.