My Account
× My Account Forum Buy Now

Last Epoch Forums

My first character reverted to lv1 when i made a second one

I made a second character and when i logged back in character selection screen my first character was lv1. I don’t know if this was the reason, but when i was making my champ i wanted to change the name and pressed the ‘BACK’ button and changed name, then proceeded to ‘Create Character’ and started to play it for a while and then quitted the game. When logged in i had my lv98 champ demoted to lv1. Luckily i googled some info and copyed my 1CHARACTERSLOT_BETA_2 and 1CHARACTERSLOT_BETA_2_temp as 1CHARACTERSLOT_BETA_1 and 1CHARACTERSLOT_BETA_1_temp, that fixed the problem.

Hope you can fix this kinda thing happening before launching the Multiplayer Beta.

Thx 4 great work!

Thanks for the report. Can’t say I have heard this one before.

Duplicate names or trying to use a name from another character that died / was deleted can cause odd things so perhaps that’s related.

The devs do read these posts so they will see this and hopefully check if the problem exists the newer version we don’t have yet.

The multiplayer capable version will allow you make online characters and the saves will be on ehg servers. You will still be able to create and play local characters but I am unsure yet how much of this process is going to be adjusted to incorporate both types of chars. Maybe they have already changed it so that what you describe couldn’t happen. Who knows.

Edit: as a precaution, I recommended you backup your save games manually so that you have an additional way of restoring your char if this happens again… the temp versions of saves can be overwritten depending on if you loaded a char again.

I have backed up my progress at 2-4 hour intervals, so my characters are safe atm :slight_smile:

Ok, i think i solved the mystery. It had created 3rd character slot save and when ever i play my second character it ‘rotates’ the slots and uses older save in login. I noticed this when i leveled my Paladin to lv100 and then continued my Acolyte to 15, after exiting the game and loading it again it used my day old save when my Paladin was lv98. I deleted the lv98 save and renamed the right ones to 1 and 2, now everything seems to work fine. I will update this if i ran into more problems regarding this save bug.

are you using Steam? specifically Steam Cloud saves?

it can do pretty odd things if it gets out of sync and needs to be reset when it dies.

if you are, then login to Steam via a browser and check what files it has in the Remote Storage.

Yes, im using Steam. Now i found out that it had created the 3rd slot again and reverted my Acolyte from lv18 to lv15.
Should i turn the cloud saving off? Is it possible to turn it off just for this game?

Ok, now whan i had only 2 character slots in the save, it overwrited the second char with the first one being there twice, so is there info in Epoch_Local_Global_Data_Beta or Epoch_Local_Global_Data_Beta_temp about the character slot ammounts? It looks that the game thinks i have 3 characters and since it changes the order of the characters in the login screen (last played on top) it messes up the saves.

Unfortunately no, those files are where the game saves all the Stash data.

the more you describe the issue the more i think its steam cloud syncing back older files but its hard to say for sure.

it could also be that you have a corrupted save that is messing with all saves (this is a known issue but described differently to what you seem to be saying…)

i would do the following:

  • post a copy of your current player.log (i would like to check it)

  • backup your saves folder (important )

  • disable steam cloud (yes you can disable it only for LE)

  • remove all files from the saves folder

  • start LE.

  • make a char and play till it levels up a few times

  • leave game (to the character screen only)

  • make another char (different class) till it levels up a few times

  • exit LE (game no longer running)

  • start LE

  • check existing characters… if all is ok, play one for a few more level ups and exit LE. start it again and check that all progress is correct or not

if everything works then enable steam cloud and tell it local files are priority. start LE again and check chars, if they are messed you know its Cloud causing the problem

play a few more levels and exit the game and close steam forcing it to do a sync…

repeat the process to check is saves are still ok…

if steam is fine, the i’d say it was a corrupted file.

Ok, now i figured out what was the problem. When i created the second character, it somehow created two character files and the game just started to save over the existing slots. Now i matched the “slot”:1," (inside save) with 1CHARACTERSLOT_BETA_1 and the same with second character. Now it works fine. I have tryed playing both chars randomly and exiting game, changing characters and the slot numbers stay the same as the character save number. Im creating a third char and try experimenting more, ill let you know how it goes later on tonight.

ok…. please post your player.log / player prev - its the games debug log… it may have something explaining what happened. it does overwrite so it may no longer have the original cause - which would’ve helped… it does provide info on things like savefile corruption.

Player-prev.log (58.1 KB)
Player.log (37.9 KB)

Are you playing on two different machines?

No, only one computer. And no VPN.

1 Like

Yeah… there is nothing in these at all… these are just typical debug files that I would expect from anyone not having any hassles playing LE version 0.8.5f

I expect that these have been overwritten since you resolved the issue manually… so there isnt anything in them thats relevant to the original problem.

worth a try…

Ok, i think it was just a glitch while making the second character and it wrote 2x save files for slots 2 and 3, then the cloudsave overwrited the real save with old one and that started this. Now i have 3 champs and all works fine.

1 Like

Keep doing the backups… :wink:

1 Like