Multiplayer issues

Been playing Multiplayer for a good while these last few days, mainly the issues we’ve been having are graphical or things not loading.
For example; sometimes when a barrel or destroyable gets destroyed we can see the destroyed image and the intact one in the same spot. Its a minor issue, and honestly creates more laughs than frustration.
We commonly have an issue where after teleporting one of the parties characters will be invisible, both in person and on the map, however their summons remain being able to be seen. It’s caused a little bit of confusion with weather or not we could continue in the quest, normally after about 5 minutes of waiting the character reappears.
We have also observed a small graphical issue where a person will teleport in and their character will be naked. It appears that weapons and armors are still on in the Inventory but cosmetically they disappear.
The most annoying bug we have encountered is being unable to use a portal or travel between maps. Sometimes the game will act like its loading (ie. give the “now loading Surface” prompt.) and de-spawn minions/companion’s, however the player will not get cut to a loading screen. We have attempted to wait it out, but that did not seem to work. The only way we have been able to clear this was to exit to main menu then reload and rejoin the other player. Its been a bit frustrating as we generally will have this happen every 3-4 travels.
Finally when going through the Tunnels to find the “Signs of Refugees” we found and killed an elite near the teleporter. After this an invisable wall seperated us, we couldnt continue forward normally. Our quick fix was to have one person teleport back to the Camp then return to the other player, the second player then teleported to the first. The invisible wall stayed however we were able to get past it so that we could continue the quest without having to re-trace and re-kill all the enemies.

I hope this helps with the development of the game, and my apologies if others have raised some of these issues already. I look forward to continue to support the Devs and enjoy this piece of art they have created. Thank You!

After reach the End of Time area having issues loading into new zones with other players in party. Loading icon above characters stays indefinitely and no loading screen ever displays. We have tried multiple different areas and can not progress more than one zone outside of citys. This also gets hard stuck, only way we found to fix is exiting and reloading into game, but then same issue will happen again as we try to progress. This didn’t seem to happen as I mentioned until around when we reached the End of time city.

Came to post about the exact same loading zone bug have to consistently wait for our teammates to relog just to be able to travel. Bumping the post.

Have this exact problem all the Time since reaching the end of Time. Solo play no problems. Only when playing with a friend.

Having the exact same problem, have played a few characters with others with 2 people, tried with 3 people, cannot load into a game with anymore.

Don’t know if its relevant - butting hitting M for the map - when clicking one of the active quests for Monolith - it does not take you to the correct end of time area - it shows the Ancient Era map where the ancient cavern is.

I have tried on multiple characters in a party of and it either sits on the area transition screen, which you can access the esc menu on oddly - when trying to start an echo the overlay prevents you clicking the Esc menu.

have also found partying with certain members does not always send a party invite.
or if i start an echo and then invite them, they portal into a world that has no floor.