Multiplayer grouping bugs

Our group has consistently encountered bugs with multiplayer. It is basically unplayable for us in the current state.

My friend can’t join me, but I can join him. (Both US-West)

  • We both start in the end of time. I invite my friend. He accepts and ports to me via “portal to player”. On my screen, he appears. On his end, he is stuck in a loading screen. Eventually closes the game.
  • Reverse: he invites me. I accept and port to him via portal to player without issue. We’re able to start a monolith run.

3 player party:

  • Lead starts in end of time. Invites, group joins via portal to player. All three join and are able to run to the first monolith and start a run. All three are US-West.

4 player party:

  • Same group, but now with one AUS player. We all group up in the end of time (Reign of Dragons). Three are US-West, one is AUS. Everyone makes it to the monolith. Party lead starts a run. Portal takes ages to appear. Takes several minutes for the slowest player. We give up and close out the game.

4 player party try 2:

  • Same group, now with the difference of grouping in end of time. This time the run starts smoothly.
  • Second echo, unplayably laggy. 362 ms. Then up to 1300 ms. Then 3600 ms. Close out the game.

two player party

  • Unable to group on first attempt without starting party outside of End of Time. Recreate party with both characters in campaign. First echo runs smoothly. Second echo shows 0 ms and characters consistently rubberband.

Logfile attached, please let us know if there is other information needed!

edit: deleted log because public posting full specs is creepy

We tried arena and experienced explosive lag after a player died.

  • Two player party, one on US-West (lead), the other US-East. After the US-East player died, they hit revive. The next round they showed 0 ms, and kept rubberbanding. Lead started rubberbanding the following wave. Client side responded, but nothing happened in the game. I noticed my wraiths also changed type. We eventually disconnected.

  • Two player party, both US-West. No issues in two runs.

We tried dungeons. We experienced progression locks, explosive lag after a player death, and difficulty connecting across regions. And a skill bug.

  • Three players, all US-West. Tier 2. The dungeon load screens were slow. At the decision to stay behind / proceed, one of us didn’t get the prompt. That player had to drop for the others to continue. The player that had to drop had never done tier 1, while the other two have (but on different characters).

  • Four players, 3 US-West, 1 US-East. Tier 2. One player dies. Uses port to return to party. Shows 0 ms. The entire party starts rubberbanding. le-51 error shows on closing out game for that player. Character remains in party. After 2 minutes we get “number of player has fallen” message, still see player in party. Disconnecting player isn’t in party on their client but still shows in group for the other three players. Logging back in, we ended up in the same instance of End of Time as though we were still grouped.

  • Two players, one US-West, other US-East. T1, no issues. Second run, T2, US-East player rubberbanded after boss died, had difficulty looting. Both players showed 0 ms. Rubberbanding player had difficulty interacting with the vault of fate, then their latency exploded. Also summoned wraiths reverted from flame back to necrotic during lag.

I’ve had similar problems, though I unfortunately don’t have logs. Took a 4-player party into the arena, all on US-west. Within a few waves, half the players were complaining of rubber banding. By the end of the first batch of waves, two players had disconnected and the other two were rubber banding. Shortly into the second wave, mobs stopped dying or spawning and abilities stopped working entirely. We stuck around for a while to see if it was just a lag spike or if it would improve, but no luck.

In dungeons, one or more players would disconnect while zoning, get kicked to the end of time, and be unable to rejoin the party. Happened in 2 out of 3 attempts

Edit: worth noting this was the same group I played with levelling from 5-60. We had a few disconnects while zoning out in the world, but nothing like the arena lag.

on my side, we manage to be almost ready to play with 2. On the other hand, as soon as we try to play with 3 or 4, we suffer from many bugs and rollbacks, until the game crashes.