Monolith Progress Blocked

Simple but frustrating bug. I cannot complete the quest state for my “Ending the Storm” monolith. I have unlocked and completed 10/10 monoliths, but it is showing my monolith quests as bugged. I have now done this monolith 3 times and have not gotten the quest state to complete.

I am stuck in regular monoliths now and can’t seem to progress.

I got same Problem but some Monoliths did finish for me…

I finished Ending the Storm 2-3 times and i still got Quest for it

There are 2 options when talking to Liath in the second quest in that timeline. One is to kill her, the other is to let her go. Have you tried both options in 2 different timeline runs? This should open both bridges, unless one of the options is broken.

You are right. That helped me, Thank you! Maybe its not buggy for me after all or only at the End like for Fribeeicarus23

1 Like

Worked for me later that day after a restart. It has completed the Monolith. Still shows a quest icon on that Monolith, but it at least let me move on.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.