Monolith Party Rewards


Wondering if anyone else has experienced the same recently. I play in a party with 2 other people and monoliths were working fine, upon completion they would get the choice between 2 rewards once an echo was completed.

Then in the last couple of days enemies started staying on the screen with health bars even when dead. This seemed to tie into them not getting any drops from certain shrines in the echo, no drops from a rune prison and when I (the party leader) complete the echo, this message doesn’t come up for them.

Once I then portal out as it showed as completed, they also portal out but don’t get any rewards from it, only I do.

Any ideas or is this potentially a bug? We want to be able to get through monoliths but doesn’t seem to want to work.

Me and my S.O have been experiencing this for the last 2 weeks.

Thanks to this. we are mostly unable to clear monoliths because enemies stay on screen.
We kept trying to play together but 9/10 times we had loading issues, no rewards, no completion due to enemies staying on screen after being killed or just flat out being disconnected by the game/infinite loading.

Sounds like you and your S/O have it a bit worse than my S/O and I! Just seems to be the party leader (me) that was getting the rewards and they weren’t. Sometimes they would freeze when using a portal and had to reboot as well.

We did maybe 5 echoes or so where it was working fine but then maybe middle of last week this started happening. The reward side of it for them was the main part for us.

Tried looking for any other posts about it but couldn’t find anything to say the same… Glad it’s not just me, hopefully the devs can fix something up for it. :slightly_frowning_face:

This is also happening to my friend and I tonight. Tried relogging, swapping party leader, swapping who initiated echo/quest, etc. no luck and strangely I’m the one not getting a single reward for anything yet still getting “credit” for completing the events afterward (but no chest, no reward so just losing out on those echoes altogether I guess except the monster xp?)

update: finally gave up and left party - strangely, when I started my own echo, it automatically had him join the same thing like he was still partied with me, but he never showed up - but the enemies were all doing the same thing again so I assumed it was still glitched. I restarted the client, started my own echo solo and it was working again, then re-invited him mid-echo and now everything is working perfectly for both of us regardless of who initiates the echo/quest.

Hi !

Yeah the same issue happenned to us last night. Enemy still on screen after defeating, no drops or rewards at the end. No portal can be spawn for finishing the map. We tried reset game, verify integrety check for update but nothing seems to work…