My Account
× My Account Forum Buy Now

Last Epoch Forums

Loot filter

If you have a loot filter applied, loot filter button “X” doesn’t disable it while pressed.

Have you remapped X to something else?

No, I haven’t changed any of the settings, I even restored back to default just to make sure.

Same issue. It works whenever I start a new session, then after a while it stops working. I do see the “Enabled” when pressed and then “Disabled” when released, but nothing shows.

I also see another glitch where an item on the ground will be Emphasized but shouldn’t be because of a filter. When I check the filters and then close that screen (without changing anything) the item isn’t Emphasized anymore.

I’ve posted this as well on Steam but no dev has ever responded. The ‘X’ key not working is much more important, especially when testing a new filter/rule.

I got the same problem.
Looking at the chat box it seems the problem is the game treating a single key press as a double press. At lest that the impression from read the text in the chat box as I get Loot filter turned off and loot filter turn on when I press the button.