Loot filter - Enable/Disable rule not applied when clicked

Hi, whenever I select “Enable or disable this rule” it doesn’t apply directly. For it to work I need to switch to another filter and switch back OR disable and re-enable the loot filter by pressing the Z hotkey to see a rule being enabled or disabled.