My Account
× My Account Forum Buy Now

Last Epoch Forums

Loot filter doesn't save when quitting game

Every time I quit the game and come back to it, I have to re-enable my loot filter because the game goes back to no filter selected, even though I only have ONE loot filter in my list and I use it for every character I make.Rares Only.
xml|attachment
(1.1 KB)

Welcome to the forum.

Are you setting the filter in the settings before loading a character or are you setting it in-game once the char is loaded?

Can you try whichever you are not doing?

Also, please can you post your player.log and player-prev.log from a session where you experienced this. The debug files may contain some extra info.

I normally select character first, then change it in the settings after.
Player.log (24.7 KB)

Player-prev.log (136.7 KB)

These are selecting loot filter before same character.
Player.log (24.7 KB)
The forum won’t let me upload my other player-prev, for some reason.

So to confirm:

  • If you set the lootfilter in-game (after selecting a char), it doesnt save the filter selected when you then exit and load the same char again.

  • If you set the lootfilter before loading a char, in the settings window, it doesnt save the filter selected when you then load the same char again.

I.e. for you neither option works and NONE of your characters filters are stored between playsessions and you have to re-enable them each time.

Is this correct?

I am personally unable to replicate this on my end and I have my filters remain active when loading in any chars - I have various ones, a default that i use for all chars and then a few others that I enable or disable for various reasons (like dropping stuff on the floor to sort for my stash).

There are however reports of similar issues with other people, but usually it has been traced to the settings filter choice overriding the in-game default filter - i.e. they still have a filter enabled its just not the one they last used - unlike yours which has no filter enabled after reloading no matter what.

The devs are going to have to investigate this further because I cannot replicate it to be able to figure out a workaround/solution.

Three things:

  1. Your player.logs are not showing any obvious debug messages about filter problems - at least not the types of messages I am used to seeing when there is a problem. Have you run a game file verification via Steam to make sure your install is ok?

  2. Have you attempted to physically remove all filter files from the filter folder and then recreating the filter from scratch in-game and seeing if this makes any difference.

  3. Your filter itself. If I understand your filter correctly, you dont need to specifically tell the game to show drops in your case - you just need to Hide the Normal/Magic ones. The filter will only apply the first rule that matches (from top down), so there is no need to specifically show drops that dont match the hide rule.

Yeah neither option works for me. I tried editing the filter to only hide items, but that didn’t work. I physically deleted my filters and made a new one, but that didn’t work either. Verifying also didn’t fix the problem.
Interesting that you’re not able to replicate it, since it seems like absolutely nothing will fix it.

It is an odd one. If it were widespread, I would expect a lot more people to have reported it already so i have no idea what the reason for it could be. As I mentioned, there is a variation of this regarding the settings vs in-game one getting mixed up so I expect that what you are experiencing is similar/related in some way.

The how and why is the tricky part.

But the devs do put all bug reports on their internal tracker so I expect that this will eventually get the eyeballs it needs - probably only once they have finished the MP push tho.