Loot Filter Broke & All Filters Impacted

I was creating some additional rules on a loot filter for specific item slots and after the third such rule, I was unable to click on the rule so I figured it was just a bug and I needed to restart the game.

I restarted the game to come back and find that the filter I was working on was broken. Anytime I try to select that filter, it switches to ‘No Filter’ (see image) and all the rules are ‘Show All Items’.

I checked my other filters and they all now had additional ‘Show All Items’ rules (see image). The difference was when I scrolled down further the other rules were still there and intact (see image).

I tried verifying the integrity of the game files to no avail. And now when I load in it takes a minute for my filters to even show up in the list (see image). I have to open the loot filter tab multiple times and each time I do it starts to show part of the filter I was working on for the character (see image). It never shows more than those 5 rules and it continues to add ‘Show All Items’ rules.

Finally, the filter I was working on had no more than 20 rules in total. I guess I will have to go through and delete these ‘Show All Items’ rules, but I am concerned that it will just keep resetting each time I log in.

I hope you all can figure out what went wrong, please let me know if you need any additional details.


Edit: I decided to try loading into another character to see if it was doing the same thing. The filters I wasn’t working on are unimpacted when I log into a different character (that isn’t trying to use that bugged filter). So it seems like an issue when trying to load that particular filter that is then impacting the rest.

Edit 2: I am unable to delete the ‘Show All Items’ rules that appeared on the filters I wasn’t working on when on the character that was editing the filter. When I am on other characters, they do not see the ‘Show All Items’ rules.

The same bug occurred.

1.Loot filer adds ‘Show All Items’ rule continuously as I add new rule.

2.After the bug happened, I cannot close loot filter window until shutting down the game.

3.This bug is only fixed when I delete loot filter file.

I think broken loot filter file causes this bug.

I just tried to get back into last epoch and was going to play offline, getting similar bug. When I select a loot filter it just goes back to no filter selected. If I try to copy and paste a loot filter in game it just says “The Clipboard does not have a valid loot filter to import”.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.