My Account
× My Account Forum Buy Now

Last Epoch Forums

Launcher Stuck at 90.1%

Hi all,

My launcher finishes downloading and gets stuck at 90.1%. I saw in one of the other threads that adding exceptions and a fresh download can fix this but it is not the case for me.

I have tried both of the above & running as administrator. The entire game downloads but doesn’t appear to install at all, the launcher just sits at 90.1% for hours. When I close the launcher and restart it it simply begins the download from scratch and deletes all the previously downloaded files.

Can someone please help out?

OS: Windows 10
Windows Defender: Exception Added
Anti-Virus: Off & Exceptioned
Running as Admin: Yes


Hi there,

Apologies in advance for a frustrating post - but could you try a fresh download of the installer one more time?

Hi Sarno,

I have downloaded the launcher again and it works!

Thanks a lot. Whatever was done, if anything haha, worked! :slight_smile:



Thanks for the update, and apologies once again for the inconvenience. :slight_smile:

Still having the same issue at 90.1%. I shut off all firewalls both Norton and Windows. I’ve downloaded the installer 4 times. Are there any other options I have to try to download. If not, I’m going to need to request my money back.

Thank you.


We’ve responded to your e-mail with a workaround while we work on a permanent solution.

Apologies for the inconvenience!