Invisible enemies and invisible dungeon bosses!

Most of the enemies on the Soulfire Bastion dungeon are invisible (I can only see the skills VFX they use, cannot see the enemies model). Soulifre bastion boss is invisible, also only can see his VFX, cannot see his model which makes the dungeon really really hard lol. Same thing for temporal sanctum and chronomancer Jurla - she is completely invisible and I just cannot see her, didin’t try other dungeons. The dungeons are unplayable for me right now. Reported it several times but I’m not sure if this is being looked into. My video settings are full hd res and medium master quality, didin’t change anything else.

I am a game developer myself and i found several of null reference exceptions in the log files, not related to the invisibiliy, but it might be a chain reaction perhaps?

Player.log (3.9 MB)
Player-prev.log (2.0 MB)


Experienced the same issues. I know you didn’t list Last Arbor, but was curious if you had problems with that dungeon as well. I can’t even connect to that dungeon without the game crashing. Hoping it gets fixed in the coming weeks!

1 Like

Same for me. Julra is invisible and I crash when trying to enter soulfire bastion or lightless arbor.
I changed all graphic settings to lowest possible, changed monitors, fullscreen and still crash.

After reinstalling everything seems to work fine again!

Player.log (4.5 MB)
Player-prev.log (5.2 MB)

1 Like

Same for Julra… completely invisible and in lightless arbor most of the monsters are invisible. About to call it for this cycle.

Having the same issue, Julra is invisible in Temporal Sanctum and I noticed during her transition, she causes a huge lag spike making it impossible to kill her tier 3+. Lightless Arbor takes almost 10-15 to load and even then only the titanspawn are visible. Haven’t tried soulfire, but I imagine something is bugged there as well. It seems as if the dungeons are bugged to oblivion. Orobyss making his way through the code of the game.

Same here. Invisible Julra, but also in other dungeon as well, i.e. Lightless Arbor does not show not only boss but also regular mobs on the way (and some does)

This is happening in various open world sections for me and my friend. It also happened in Last Arbor, where I could no longer see any enemies, but somewhat interact with them. It made my Amber no longer light up the area and all, meaning I died pretty quickly once my party member died, effectively wasting my key about 30 seconds into the dungeon. It happens multiple times in every play session so far with the two of us. Generally, portalling to town and coming back fixes it for whoever has the issue, but you can’t do that in a dungeon without wasting the attempt.

Any update on this matter from the devs? The game is unplayable since all of the dungeons are literally broken for me and cannot craft legendaries and such. Very annoying, about to quit the cycle…

After Patch 1.0.3 it actually started to work! =)

Entire zones are disappearing, no mobs, not map, not graphics but my character standing in the middle of the zone, with a purple screen.

I did not check dungeons, but I can also confirm strange invisible mobs bug while doing monoliths.
The strange thing is, that during my (4h) session yesterday this bug was coming and going, and some mobs were visible. So perhaps it is linked to specific enemies.
I tried to restart the game, then also restart my PC. Lower my grafic settings, but nothing worked.

Been having this problem for a few days now. Happens in campaign areas and in Light Arbor dungeon. Very frustrating. Made sure my drivers are up to date. Relaunching game and rebooting does not help.

I ran the steam verify which found two bad files, re-applied them, and now the problem has gone away.

1 Like

I uninstalled the game completely, then re-installed it and now it works. Perhaps steam verify would have also helped.
Hope this helps anyone with similar issues.

This isn’t a fix, but I hope the devs see this one and it helps find the issue:

I’ve had the issue sporadically and while fighting on a bridge I realised that the mobs aren’t actually invisible, but are being placed too low so they’re under the map.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.