Heorot's last blessing quest stuck

2023-03-14T23:00:00Z Online mode with a friend, the Heorot’s quest is stuck.
It appears on the map (?), but there is no blue aura on the door to go through it.
We can go around it to the Scortched Groove by the south and see Heorot’s death but when we come back, the quest to visit Heorot is still active, still no way to use the door from Heoborea to The Solemn Path and trigger the quest.


I’v had the same issue, i have no clue how to fix it, hopefully the devs find this bug, and patch it

Same here, i have no clue what to do now :frowning:
Edit: I was able to continue the storyline by teleporting to a friend that was in “Deep Harbor”, the area south-west of “Heoborea”. Just ask in the chat if you don’t have friends to play with :slight_smile:

Had the same problem. Is Grael standing right next to Yulia in Heobora? If not, you need to go to the Temple of Heorot, go to the end, fight the boss, and go through the portal to Farwood. Keep going and you should see Grael, he’ll give you a quest to get the lance, which is what you need to finish in order to open the path to Heorot from Heobora.

Yep, that worked for me too. Thank you Frozenwest! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.