My Account
× My Account Forum Buy Now

Last Epoch Forums

Game won't start (Linux) on Arch/Suse

I don’t know if it’s my 2k monitor not allowing launcher to go or what, this is i7-vega mini PC (not a toaster) and both arch and suse (not my main distros) refuse to launch, laucher > connecting > disappears. Got not no ideas, I have played the game on this PC before, just been >6 mo. Any advice??

Unfortunately, the game won’t install on pretty much anything but *buntus. I use openSUSE and I had to install through Steam. Sadly, it works better using the Windows version and Proton.

Actually the game works fine on Suse! download a new launcher from your account and reinstall it - that will work it was a permissions issue from copying the entire Linux folder from offline.

I tried that 3 days ago when I reinstalled Tumbleweed. It still does what it always has. Starts the install then fails with a Network error. There are numerous threads allover these forums with the same error on non debian based distros.

works fine on ARCH, NO GO on SUSE at all, tried everything I could