Game crashes on selecting a character without a VPN

Created a character, clicked enter game, loading screen, popup of a crash but immediately goes to the background, game not responding for a second, and then it closes out.

This happens without VPN, with VPN the game works fine.

I live in North Africa region, closest server is EU West with about 60 MS to my location. With Ping it grows more but it still works no problem so it isn’t a distance thing.

This also happens to my friend who has a completely different setup but lives in the same city (Cairo, Egypt).

I checked the stack trace for any meaningful logs and it seems there is a rather interesting message in the logs:
Ping: Error performing ICMP transmission. Possibly because of a timeout

Could it be ISP related that it blocks the Last Epoch server address/ports for some reason? (My ISP is called ‘WE’)

Can I get any URL to try and ping from a CMD prompt to test and see if its ISP related? Need any kind of support here please devs.

I am attaching the log files for you to take a look at as well:
DxDiag.txt (95.8 KB)
Player-prev.log (663.1 KB)

Thanks!

@Averielle @Wick_EHG @DiJi_Mon

Given I know that Averielle had been looking into similar issues and collecting details, I spoke to Olam on the Discord briefly. They suggested I should ping you here :slight_smile:

Thanks for the ping.
We are currently looking into this but, we have found that this issue could be due to Egypt’s restrictions on certain websites and servers. We had this issue with other players and found that the best resolution was for them to ask their ISP to manually unblock Last Epoch.

Perfect, so can I have an address which I can ask the ISP to unblock then please???