My Account
× My Account Forum Buy Now

Last Epoch Forums

Game closes after selecting character

After Login, on character select. I can choose who to play as normal but after the loading screen (displays fine, can see the council chambers art and tool tips) the game just closes, no warning or nothing.

It happens on only one of my current characters, a level 9 Sentinel, trying to load into the Council Chambers. I have a level 68 Druid, who I can login with and play fine, no issues, but if I try to switch to my other character (via Leave Game) the game will just close, no crash or freeze just gone.

This only just started happening today and weirdly I cannot find a relevant topic in the bug reports (sorry if i missed it).

Hello! If you have not already tried it, validating your game files through Steam might help the issue.

Right-clicking on the game in Steam, clicking Properties from the menu and then navigating to the Local Files tab should show a button that says “Verify Integrity of Game Files”

Just tried that and it has worked, thank you very much :slight_smile:

Glad to hear it!