My Account
× My Account Forum Buy Now

Last Epoch Forums

Fury Leap not leaping with Rise

Operating System: Windows 10

Detailed description: Since I put points into Rise on the Fury Leap tree I will sometimes not leap when I use the skill. I put 3 points in to Rise so I could start putting points into Poisonous Thicket and Poisonous Thicket procs sometimes when I do leap but I haven’t seen Rise proc even once. When I use Fury Leap the animation always starts. My character raises his weapon as if to leap but when he doesn’t leap he just goes back to standing animation. Sometimes when he doesn’t leap Fury Leap will go on cooldown but the majority of the time it doesn’t. When it does go on cooldown the landing animation will happen about 9 seconds later in the place that Fury Leap was used even if my character is no longer in that location (this doesn’t move my character.)

How consistently does this happen? I tried the skill 100 times while the character had 3 points in rise and 4 points in Poisonous Thicket. 45 times only the starting animation happened and the skill didn’t go on cooldown. 34 times it went on cooldown, the starting animation happened, and the landing animation happened in the same place as the casting 9 seconds later. 21 times the skill happened as normal with 13 of those procing Poisonous Thicket.

I tried again after putting 5 points into Rise and it always goes on cooldown and never leaps.

Thanks for the report!

This issue should be resolved as of Patch 0.5.4.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.