Echo's not loading

There is a problem running echo’s, not sure how many players encountered this “bug” but after almost every echo i have to ALT+F4 and load in again because the echo doesnt load…


I am experiencing this for the “ransached camp” or whatever its called. The first quest of the first timeline conduit. Tried it a few times over the past few hours but just hangs in an infinite loading screen

Are there other Monolith Quests that you can enter that do work? Do normal Monolith zones work?

in contrary to the OP normal echoes do work.
However i have no other timeline quests to check if they work as i have not unlocked any other timelines. I am softlocked now…

Player.log (65.7 KB)

I have also encountered the same issue trying to enter Lightless Arbor today. Had to alt+f4 numerous times but no luck entering it.

Are you playing Solo Online or with a Party?

We’re currently looking into issues concerning this.

You could potentially try hitting “Leave Game” after entering the game for the first time and then attempting the Dungeon again instead of fully closing out of the game.

i am playing solo online

Thanks for the response, we’re still looking into this. Does attempting to verify your game files through Steam help at all?

1 file was corrupt and was re-aquired. Now i can enter the ransacked camp. Seems to have solved the issue!

I verified as well and it seems better now, so hope that was the issue

How to do that verify thing? I’m experiencing the same issue stated above. Ty!

Right-Click on the game in Steam then go to Properties from the drop-down menu, click the Local Files tab and then press the Verify Integrity of Game Files button.