Echoes are unplayable: every 2nd echo I play breaks and everything lags. HELP!

tl:dr: 1st echo is fine, 2nd echo always unplayable with invisible enemies and skill effects, rubberbanding and death. The rest of the areas of the game aren’t affected.
Only happens during EVERY 2nd echo. 1st Echoes are fine. Relogging fixes this for 1 Echo.

Every 1st echo after I start a game always run smooth but every time I zone into a new (2nd) echo the first 20-30 seconds and sometimes a couple of MINUTES consist of running in place, rubberbanding, and invisible enemies. If lucky i can run 2-3 before its completely unplayable after that i have to restart a game then i can run 1 echo and everything is broken again.
I tried to run new character and campaign zones are perfectly fine but endgame echos are unplayable. My game connects shows a 70ms so I have no idea what is causing this.

1 Like

Having the same issue. 2nd echo breaks the game and have to restart just to do 1 echo. Connection is around 20-60ms. Campaign was smooth. Verifying game files did not help. Game is also on the list of allowed programs in firewall. Playing sorcerer in online mode.

Same issue here. I notice the issue is worse in some maps. The arena style maps and boss rooms have no issue and loads instantly.

Got the same issue on my sorcerer its unplayable so I have made a necromancer until this issue is resolved unfortunately. This only occurs on my Sorcerer no other class is doing this that I use.

Arcane Ascendance specced into Acuity on the skill bar is the issue it seems…
Remove it from skillbar or unspec from Acuity and this wont happen.


Yep. It’s Arcane Ascendance with Acuity. Idk if it is related, but it allows you to cast 5 spells instead of 4 before the buff ends. I find that the 1st echo is ok, the 2nd desyncs a little bit, and the 3rd is unplayable. You can fix it by unspeccing from acuity for now until it is fixed. It works fine in the campaign, only echoes that this will happen. Idk about dungeons, but in my soulfire bastion run last night it worked fine with acuity specced.


I’m not seeing a correlation between arcane ascendance w/ acuity and bad lag. I have been lagging really badly last few days, have another thread about it.
Today I played with and without arcane ascendance, and I had no lag 99% of the time with and without it. I’m guessing the servers are a lot less stressed with people playing that other game’s beta weekend right now.

If I start lagging again (maybe Monday when people come back to LE) I’ll test with and without arcane ascendance and if I see it makes things worse, I’ll reply back here.

Having your Player.Log files would be a big help for issues like this along with your timezone. It’ll help us locate and identify issues that might be occurring serverside.

I’ve had no issues after I respecced out of that node

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.