My Account
× My Account Forum Buy Now

Last Epoch Forums

Controller Keybind Changes not saving after client restart

Seems that any controller keybind change is not persisting after restarting the client and disconnecting the controller. All controller bindings revert to default.

However, if i keep the controller connected to the PC and restart the client, then it is saving correctly. And if I keep the client on and disconnect/reconnect the controller, keybinds are still saved.

This is only an issue if both the controller is disconnected and the client is restarted.

Playing through Steam with a Switch Pro Controller.

Same issue with an xbox one controller as well. The game seems to not remember controllers? Game always marks it as XInput 1 Gamepad when connected, and resets all binds back to default.

Any chance you could give me a vod of it not saving for you?

I just tested it myself and it is saving my controller settings correctly after I altered two commands → clicked “Done” → exited and relaunched the game.

Here you go: Last Epoch Controller Binds resetting - YouTube

I disconnected my controller after exiting the client and reconnected after being in game. I re-bound three keys and then on client + controller restart, all keybinds are back to default.

(Also, you can see before i exit the client, i lost control of my character, the input kept switching from controller to keyboard, but that was probably nvidia shadowplay causing that, since I had never seen that before).

Hm. Looks like when you log in you got a steam notification about your config changing on your controller. Could that be defaulting your settings back?

No, it just says “Using configs from <steam profile>”, which is just what Steam says when I connect my controller. This is normal for any game on Steam.

Again, this resetting problem only happens if i exit the client AND disconnect my controller after changing keybinds. Once I restart the client and connect controller again, everything is default. If I only do one or the other, keybinds are saving/restoring correctly.

Is there a local file on my machine that has the current keybind configs?

I attempted to reproduce using your steps and disconnecting my controller as well and it wouldn’t defaulting back for me. Changing the config locally wouldn’t to my knowledge fix this problem because it seems to have something overriding your changes.

Hm, well I have tried a lot of stuff, but nothing is working. Also tried on my wife’s computer, and it also resets all controller custom binds on client restart + controller disconnect. I have also tried doing a full re-install of the game through Steam.

I’ve tried with both a switch pro controller and a Xbox One Wireless controller on Win 10. Both run into the same issue on two PCs (both running steam).

Turning off the steam overlay didn’t change anything.

Using a switch pro controller, Steam has a compatibility setting to make it a regular xpad input, and turning that off didn’t work; that just added more problems (turning on the controller without this compatibility made me lose control of my character, he just kept running south until I turned off the controller).

The only thing I have found that works is to never turn on the client without the controller already connected. That’s the only way LE seems to pull the saved controller config. If I launch the game without the controller present, the controller config resets to default.

Really more of an annoyance than anything else. My RSI is flaring up again, so I definitely need the controller to play.