Channeled skills stopped working after 0.9i

Noticed that all channeled spells (where you hold down right click for example) stopped after the update today. Rampage on my Werebear stops after just 1 second and goes on cooldown, no matter how long I hold the button. To test something else I logged on my Paladin and tried to use Warpath. Same result. Skill is used for ~1 second (or 1 spin) and is then put on a 0.5 second cooldown. Resulting in a some sort of stutter-Warpathing, which isn’t usable in it’s current stage.

had this happen to me with acolyte/lich “Drain LIfe” also–my character spams the start of the channel animation and sound, i dont lose mana, but i dont do any damage, making it unusable

It was sujested in another post but worked for me.
The chaneling isnt working o “R” bind
But changing into “Q” it works.

something rong with the fouth slot aparently.

i thought i tried swapping buttons around and even relogging, but i’ll try it again next chance i get

Focus doesn’t work on W and E bind, had to move it to Q. Happened right after this patch

Confirmed: Draining Life does nothing, isn’t on the curser…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.