Cant unlock empowered monoliths

So ive done all 3 lvl 90 monos and completed them. i have blessings from each 90 zone. but when i go to unlock the empowered nothing happens. no camera pan out or anything like that. so i redid all 3 lvl 90 zones and still nothing… heres some screenshots. hopefully someone has a fix for this, not really sure what to do anymore. thanks <3

screen shots :

P.S. im an ONLINE char.

i could not get my regular screen shots to post so i had to upload to imgur, hopefully that works for you guys.


There is some known bug with this empowered rock. I think they fixed it in offline but online still has some issues

As a workaround, you can try grouping with somebody who already unlocked them and teleporting to them in the zone.

do you have them unlocked? would you be willing to try to help me?

so that auctually worked… wow thank you.

Glad it helped :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.