Can't move after using Dancing Strikes

Hello there,

I started a Rogue and went the Blademaster way, everything worked smoothly yesterday.

Today, I just logged in and I am unable to move after using Dancing Strikes.
Basically, everything works fine until I press Dancing Strikes.

I tried using Dancing Strikes on a different keybind but issue remains the same.
As soon as I use Dancing Strikes, I get stuck after the spell animation.
However, using another skill gets me unstuck but it is unplayable honestly.

I checked online and found this Reddit thread from yesterday :

I tested it, and I have the exact same issue : Shadow Cascade does no damage at all.
Please note I don’t know if it is any different from yesterday regarding Shadow Cascade, as it was not part of my build. I didn’t try it earlier.

Here are a few screenshots with my UI/Keybinds and specs, if it helps :

Basically this is a build from MaxRoll :

Thanks in advance for your support !

Found why !

I had only one weapon equipped, the other one was in my Forge…
Equipping the second one fixed it !

Mine is doing the same thing with both daggers. But my offline character is fine. Not sure what’s going on

Same here. It works if I spam button, but if I press and hold there is significant pause between uses, where my BladeDancer just waits, for 0.5 seconds or so.

Dancing strike delay bug - Bug Reports - Last Epoch Forums

there is similair report already. Its a bug, waiting for the fix.

I am still having this issue. It is not everytime i use Dancing Strikes, but around a destructible environmental piece or a chest, i get permanently stuck everytime. Has been happending since Tuesday 3-14, and still happening today. I restart and sometimes i am fine for an hour or so, then it happens again.

Same here.
If i spam the button for the skill, it works fine. But if i hold it, the attack triggers once and then pause for 1-2 seconds before the next attack comes.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.