Can't Abandon Challenge Solo AF

My Character died and went from Hardcore to Softcore Solo Account Found.

My Problem is I can’t seem to Abandon Challenge to convert the character to a normal softcore character.
I click the option under Challenges to disable solo challenge , and on the “Are you Sure” I click Abandon Challenge. But nothing happens.

I even created a new Character and attempted to remove that character’s Solo Account Found Challenge, and nothing happened.

Verified my files on Steam. Tried again. No Change.


I am experiencing this as well due to the wording of the challenge description being misleading. It makes it seem like selecting it will make your stuff shareable but it is the opposite.

I’m trying to abandon the challenge before I spend too much time on this character and end up losing my gold and good finds.

When I go back to character selection it says I am no longer using the challenge but it is still there when I go back in game.

Same here.

Seems like feature is broken. Finished story with necromancer and wanted to bring her back to the ‘family’, but seems like accepting warning message does nothing. Hey, Devs, how about you fix this?

I had the same problem. I succeeded when I tried it as a low level character, but it didn’t work for the 88 level character.